summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-13 18:50:07 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-13 18:50:40 +0200
commitf04279a491165d84f5120dddaf30c7cd007cd037 (patch)
tree0f4351d375819accd87ec79acf181f98a00cdf07 /dev-python/doublex
parentmedia-radio/tlf: Fix failig test (bug #740298) (diff)
downloadgentoo-f04279a491165d84f5120dddaf30c7cd007cd037.tar.gz
gentoo-f04279a491165d84f5120dddaf30c7cd007cd037.tar.bz2
gentoo-f04279a491165d84f5120dddaf30c7cd007cd037.zip
dev-python/doublex: disable broken tests, support Python 3.9
Closes: https://bugs.gentoo.org/737926 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/doublex')
-rw-r--r--dev-python/doublex/doublex-1.9.2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/doublex/doublex-1.9.2.ebuild b/dev-python/doublex/doublex-1.9.2.ebuild
index 48f7f302a18b..167fc6a19c20 100644
--- a/dev-python/doublex/doublex-1.9.2.ebuild
+++ b/dev-python/doublex/doublex-1.9.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1 vcs-snapshot
@@ -27,6 +27,16 @@ RDEPEND="${CDEPEND}"
distutils_enable_tests setup.py
+python_prepare_all() {
+ # Disable broken tests
+ # https://bitbucket.org/DavidVilla/python-doublex/issues/5/support-for-python-36-37-38-tests-failing
+ sed -i "s/test_*hamcrest_/_&/" doublex/test/report_tests.py || die
+ # https://bitbucket.org/DavidVilla/python-doublex/issues/6/more-failing-tests-with-python-39
+ sed -i -r "s/test_(proxyspy_get_stubbed_property|stub_property|custom_equality_comparable_objects)/_&/" \
+ doublex/test/unit_tests.py || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
use doc && emake -C docs
}