summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 15:30:07 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 15:31:00 -0600
commit24f3332e2126cbdac017501fd8926da1bf822162 (patch)
tree77e1cd90827279631b5fb6a966cd9d5bf1172445 /dev-python/drf-yasg
parentnet-libs/socket_wrapper: Drop 1.1.6, 1.1.7, 1.1.9, 1.2.1 (diff)
downloadgentoo-24f3332e2126cbdac017501fd8926da1bf822162.tar.gz
gentoo-24f3332e2126cbdac017501fd8926da1bf822162.tar.bz2
gentoo-24f3332e2126cbdac017501fd8926da1bf822162.zip
dev-python/drf-yasg: 1.17.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/drf-yasg')
-rw-r--r--dev-python/drf-yasg/Manifest1
-rw-r--r--dev-python/drf-yasg/drf-yasg-1.17.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/drf-yasg/Manifest b/dev-python/drf-yasg/Manifest
index 345b2aff4ac6..39af47b29158 100644
--- a/dev-python/drf-yasg/Manifest
+++ b/dev-python/drf-yasg/Manifest
@@ -1,2 +1,3 @@
DIST drf-yasg-1.14.0.tar.gz 1270930 BLAKE2B 11c075fecf1e0742765ebcab27ffda719867e4d49f5e6f337d2d048dea26e3fd1585f42a2bc58808395ff3ef2e1c5aae912d5ab547f91be5b3f0bc3a0ebae98e SHA512 283307cecfc0c8fe97a8742780184bd73b547f9cd4e28bafd35cb1447519f65a432f112627fc7f5e9560185014d0477a9bf507c1cb9afcbdc3f58a21a7dd351f
DIST drf-yasg-1.16.0.tar.gz 1288698 BLAKE2B cc27c5da43a20a21af8b775b891ae4f528bbe6db570f4af0008d3ca0d7ae404a20e9781985c567e880d584f219fa819709e7fcb0bcf851f5ab2ecf9d5122186f SHA512 f13abe5647df15c241abe3569eb2f12865cca77777018898240da7b2d7a583c362b4fd1f8a6bf57de0efb27a19a2e8e894edf74d83d82b4d69b80ed56c4836d4
+DIST drf-yasg-1.17.0.tar.gz 1299955 BLAKE2B a2fe34a7cc37fdaed471ce4d7d8e9f0df2f5945ead412d4a2e7ef42f8867c346f66ca95dce4f65e64854b3b4265ee99f3c97c19412084c359bb47896b1925944 SHA512 90cc3ebe0208be721b34b1f33c23caa4aa4055bd41a694dc562e9819a14a8f92494b2ab26d3993378fd56ce0542fba294405b719c899f11f30478d0cc064560d
diff --git a/dev-python/drf-yasg/drf-yasg-1.17.0.ebuild b/dev-python/drf-yasg/drf-yasg-1.17.0.ebuild
new file mode 100644
index 000000000000..db8d6123062f
--- /dev/null
+++ b/dev-python/drf-yasg/drf-yasg-1.17.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Automated generation of Swagger/OpenAPI 2.0 schemas from Django Rest framework"
+HOMEPAGE="https://github.com/axnsan12/drf-yasg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+validation"
+
+RDEPEND=">=dev-python/coreapi-2.3.3[${PYTHON_USEDEP}]
+ >=dev-python/coreschema-0.0.4[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15.34[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-3.8[${PYTHON_USEDEP}]
+ >=dev-python/django-1.11.7[${PYTHON_USEDEP}]
+ validation? ( >=dev-python/swagger-spec-validator-2.1.0[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"