summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-13 00:14:34 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-13 00:47:15 -0600
commit4ff8f8f22716cc299e3691675f36aa89e0c89b6d (patch)
tree86c07d4819bd616d16768f3063d1b8628cca0583 /dev-python/dugong/dugong-3.7.3.ebuild
parentdev-python/attrs: version bump to 18.2.0 (diff)
downloadgentoo-4ff8f8f22716cc299e3691675f36aa89e0c89b6d.tar.gz
gentoo-4ff8f8f22716cc299e3691675f36aa89e0c89b6d.tar.bz2
gentoo-4ff8f8f22716cc299e3691675f36aa89e0c89b6d.zip
dev-python/dugong: add python3_7 support
Note that >=pytest-3.3.0 merged the catchlog plugin so use it for 3.7 support. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/dugong/dugong-3.7.3.ebuild')
-rw-r--r--dev-python/dugong/dugong-3.7.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/dugong/dugong-3.7.3.ebuild b/dev-python/dugong/dugong-3.7.3.ebuild
index e1144b98f8bd..c074de2aed17 100644
--- a/dev-python/dugong/dugong-3.7.3.ebuild
+++ b/dev-python/dugong/dugong-3.7.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{4,5,6,7} )
inherit distutils-r1
@@ -18,7 +18,10 @@ IUSE="doc examples test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ || (
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.3.0[${PYTHON_USEDEP}]
+ )
)"
python_test() {