summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-22 01:23:29 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-22 02:07:06 -0400
commit5cbf39c2f81e17a12282b0d74e51fd6ed5fdd89a (patch)
tree9d358a92c490c8dba4250844df010aa1552211b7 /dev-python/dugong
parentx11-misc/py3status: version bump, bump eapi and python_compat (diff)
downloadgentoo-5cbf39c2f81e17a12282b0d74e51fd6ed5fdd89a.tar.gz
gentoo-5cbf39c2f81e17a12282b0d74e51fd6ed5fdd89a.tar.bz2
gentoo-5cbf39c2f81e17a12282b0d74e51fd6ed5fdd89a.zip
dev-python/dugong: version bump to 3.7.1
Diffstat (limited to 'dev-python/dugong')
-rw-r--r--dev-python/dugong/Manifest1
-rw-r--r--dev-python/dugong/dugong-3.7.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/dugong/Manifest b/dev-python/dugong/Manifest
index fe35b20d9d69..41dc2c7a0c07 100644
--- a/dev-python/dugong/Manifest
+++ b/dev-python/dugong/Manifest
@@ -1 +1,2 @@
+DIST dugong-3.7.1.tar.bz2 194243 SHA256 3bf01631c4ccd1be2b07aa0adcda94b8627457207cd5cd7f8438c0d7fad63509 SHA512 85c276bba85d650bf0baa6257bf0872cb2da546a23d19e0c94cc15c95721a8d9f6392db0e64b38ab2e801803e3ab7908e6a931d18736d33c87138eca35b4f27c WHIRLPOOL 5d229cc20ce27f295068ce92d77092e69f21ce72ddd511478b902e421e9061d79df1325b67abe0205ca21b1bec559a5069f74c56ed0fa1cbb60213b473c15f07
DIST dugong-3.7.tar.bz2 193975 SHA256 68f7810742e1c54a5cddfa49992d416704c13b25263bd3278f7581cbc2adb2e1 SHA512 f6e637946ec5f402a21dc40f08ab187bed281b4b7c27c056651eac049d9aaf4c952bfa5e19c05db6cac2d284cf7dbd47250b82cdbcac998971fd10466a47fe21 WHIRLPOOL 3ee51fc0f085f94f64d04b6ef04fb69db8f4a569347eee4fbb1e18727343752dbf6b7df080776ca38b87f49d8495b5bd6361eb25f3cd12b4bc54b911be96a87c
diff --git a/dev-python/dugong/dugong-3.7.1.ebuild b/dev-python/dugong/dugong-3.7.1.ebuild
new file mode 100644
index 000000000000..d5bddcb825e4
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}