summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-09-14 00:38:12 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-09-14 00:38:12 +0200
commit3e17ef985ff751434282c24fa55a10c2bc44c7e1 (patch)
tree9c10386a96bddb286a636d3da5e13b6486826096 /dev-python/dulwich/dulwich-0.11.1.ebuild
parentmedia-video/ffmpeg: bump to 2.8 (diff)
downloadgentoo-3e17ef985ff751434282c24fa55a10c2bc44c7e1.tar.gz
gentoo-3e17ef985ff751434282c24fa55a10c2bc44c7e1.tar.bz2
gentoo-3e17ef985ff751434282c24fa55a10c2bc44c7e1.zip
dev-python/dulwich: Version bump. Adds python3 support
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/dulwich/dulwich-0.11.1.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.11.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/dulwich/dulwich-0.11.1.ebuild b/dev-python/dulwich/dulwich-0.11.1.ebuild
new file mode 100644
index 000000000000..77b59d28f652
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.11.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/gevent[$(python_gen_usedep python2_7)] )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/jelmer/dulwich/issues/196
+ if [[ "${EPYTHON}" == pypy ]]; then
+ "${PYTHON}" -m unittest dulwich.tests.test_suite || die "Tests failed under pypy"
+ else
+ emake check
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}