summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-08-15 15:18:07 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-15 21:45:29 +0200
commit061276cf57138c5b9ac69c33b782af519b46a8a7 (patch)
tree331a57322cd0d25102a65c04f1e1eea08281a9a3 /dev-python/dulwich
parentdev-python/python-fastimport: update HOMEPAGE and LICENSE (diff)
downloadgentoo-061276cf57138c5b9ac69c33b782af519b46a8a7.tar.gz
gentoo-061276cf57138c5b9ac69c33b782af519b46a8a7.tar.bz2
gentoo-061276cf57138c5b9ac69c33b782af519b46a8a7.zip
dev-python/dulwich: bump to 0.14.1
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2085 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.14.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 84b4cdd55ddb..cb0b60df742b 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,4 @@
DIST dulwich-0.12.0.tar.gz 293900 SHA256 8f9070f37eec6175aab60d7064246b5b6453b2fab342589101f1c8feda0a0cc6 SHA512 55062a89d77294df849a8f59e0dd25c4d557fc3ea8e2de2c114c510ebe15ba876be54fad0889f1475855e3bf986f91e04b819dad3fe61f23b399553b59b26302 WHIRLPOOL b244e9269d9e452edc39c020772649ca86b91ab3ac88e9f1a212022b5c93719909039017a6cb5543a949a17c93a523e86b4cfc7985233b3e105d12446fb3f1c4
DIST dulwich-0.13.0.tar.gz 289213 SHA256 8ed35334e22cf93e7dcfd5113d8e262041967fe4c3cead5e262c9102f3e63238 SHA512 5d62f81f45701c4e543483c89db696295b8c6aff413fa595a704b27421d5e0a99132a5c19c9b5511f96261c6a2c7d96e269ce9da526dec001b9a2fbc41413812 WHIRLPOOL abdc1877dbdc4499fbf888635287892376c58007515b32cd48d25662519e4708a79aa6f9b6b6b60b282b5f86646c0c6ca36c29516a0bf864bb998a2f4bd8216f
+DIST dulwich-0.14.1.tar.gz 292827 SHA256 7c1f49e6e72fa8635328d32bfeb7103e86e175d87fa80a9cefdd63a360f7ba93 SHA512 95c996c101fa591bb5f94f98ad3c3b2426e678a0d5ee663fb42a8b2e93bb220e9fd18d3e943d3dbc913098111e1dd090f0751a17e1b71431a2175dcd3b711ea2 WHIRLPOOL 495a33fa1fb34368008a9c73acb3185032805f4e11a180022c7236b05c421d4ba71d32958d6ea9a602fdf238b83a23feb2c50a30726bad504978705b426b7d4f
DIST dulwich-0.9.9.tar.gz 270127 SHA256 084e762c8d4d0c0002823249db57b8e735c99c409dacc2849565dd3c0c288496 SHA512 5039e8e80c51b8ee0df2ba0805fa63d9b476a05c86b6bd9eaf9348ac03a83f0f1208e259ae6bcf40fb2c94ffb57c9b45bff852e367b8bee95c10e672d3dc19d5 WHIRLPOOL 2a79d25f1233d9a6a242d064af179486810555eb3c9803c336ae152095318a32eb8588779cb07f84b073a05bf7f083ba3b3d4c8d2b4f8929b2aa3d01c29a0a01
diff --git a/dev-python/dulwich/dulwich-0.14.1.ebuild b/dev-python/dulwich/dulwich-0.14.1.ebuild
new file mode 100644
index 000000000000..8b30685f3642
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.14.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake check
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}