summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dynd-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dynd-python')
-rw-r--r--dev-python/dynd-python/Manifest2
-rw-r--r--dev-python/dynd-python/dynd-python-0.6.5.ebuild75
-rw-r--r--dev-python/dynd-python/dynd-python-0.6.6.ebuild73
-rw-r--r--dev-python/dynd-python/files/dynd-python-0.6.0-out-of-git-versioning.patch13
-rw-r--r--dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch14
-rw-r--r--dev-python/dynd-python/metadata.xml13
6 files changed, 190 insertions, 0 deletions
diff --git a/dev-python/dynd-python/Manifest b/dev-python/dynd-python/Manifest
new file mode 100644
index 000000000000..97437440fdff
--- /dev/null
+++ b/dev-python/dynd-python/Manifest
@@ -0,0 +1,2 @@
+DIST dynd-python-0.6.5.tar.gz 231313 SHA256 63552c19d7da7a6dd417d75de45af61aa70f336e09d48fea0f5f9f571b41785d SHA512 46af19bc26c8f410ac26d4e756a726a56f2d852bfa21dca03c4c47210ed9074a7e017bdd2ecb1de3d00af37815b4a20885cd7945af4c8536941e9106bcf49f12 WHIRLPOOL 7a8941b0b678f4cf83eea7906ef060afa60a3d3168ca1a375ba8349b26cdba2437624150b8494d8f26bbb80f4cf4a8ca30685fb38aa9088b62e7df927dcdc8e0
+DIST dynd-python-0.6.6.tar.gz 233618 SHA256 cfd71413832c8c44f8357268ffce99f013184c339bfda5a9186610e57f32644d SHA512 c6be9acf0a4dd2446d613cc0c251b56fcd529fac733ecd63d0450806d7f4af2191ef4e861d015177140ca997464b591562a9f478ea83638516fab8552ee88c06 WHIRLPOOL b60e3d774fab77df19788b6eb8f812a19126a109ca7158de7eed2ffbacb3da7866935c39da985323dba3e79817225732d4ebd27d584913709ab527dbf05781ad
diff --git a/dev-python/dynd-python/dynd-python-0.6.5.ebuild b/dev-python/dynd-python/dynd-python-0.6.5.ebuild
new file mode 100644
index 000000000000..222419ecfad9
--- /dev/null
+++ b/dev-python/dynd-python/dynd-python-0.6.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils python-r1
+
+# change each release, to avoid git in tree dependency
+DYND_GIT_SHA1=e5578b6b862c025dd757f77aaae69be48cde5613
+
+DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
+HOMEPAGE="https://github.com/ContinuumIO/dynd-python"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc test"
+
+RDEPEND="
+ ~dev-libs/libdynd-${PV}
+ >=dev-python/numpy-1.5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.2-out-of-git-versioning.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # each relase comes with a different set...
+ # remove forced strong flags
+ sed -i \
+ -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
+ -e "s|@DYND_VERSION@|${PV}|" \
+ -e 's|-g -fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SEPARATE_LIBDYND=ON
+ -DDYND_INSTALL_LIB=ON
+ $(cmake-utils_use test DYND_BUILD_TESTS)
+ )
+ python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+ use doc && emake -C doc html
+}
+
+src_test() {
+ testing() {
+ cmake-utils_src_make DESTDIR="${WORKDIR}-test-${EPYTHON}" install
+ cd "${WORKDIR}-test-${EPYTHON}"/$(python_get_sitedir) || die
+ ${PYTHON} -c 'import dynd; dynd.test()' || die
+ }
+ python_foreach_impl testing
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+ dodoc README.md
+ use doc && dohtml -r doc/build/html/*
+}
diff --git a/dev-python/dynd-python/dynd-python-0.6.6.ebuild b/dev-python/dynd-python/dynd-python-0.6.6.ebuild
new file mode 100644
index 000000000000..ac4f487841c9
--- /dev/null
+++ b/dev-python/dynd-python/dynd-python-0.6.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit cmake-utils python-r1
+
+# change each release, to avoid git in tree dependency
+DYND_GIT_SHA1=d7ec36c6f1beb0621d6037ab0953db7e4c1b9150
+
+DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
+HOMEPAGE="https://github.com/ContinuumIO/dynd-python"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ ~dev-libs/libdynd-${PV}
+ >=dev-python/numpy-1.5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.2-out-of-git-versioning.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # each relase comes with a different set...
+ # remove forced strong flags
+ sed -i \
+ -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
+ -e "s|@DYND_VERSION@|${PV}|" \
+ -e 's|-g -fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SEPARATE_LIBDYND=ON
+ -DDYND_INSTALL_LIB=ON
+ $(cmake-utils_use test DYND_BUILD_TESTS)
+ )
+ python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+ use doc && emake -C doc html
+}
+
+src_test() {
+ testing() {
+ cmake-utils_src_make DESTDIR="${WORKDIR}-test-${EPYTHON}" install
+ cd "${WORKDIR}-test-${EPYTHON}"/$(python_get_sitedir) || die
+ ${PYTHON} -c 'import dynd; dynd.test()' || die
+ }
+ python_foreach_impl testing
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+ dodoc README.md
+ use doc && dohtml -r doc/build/html/*
+}
diff --git a/dev-python/dynd-python/files/dynd-python-0.6.0-out-of-git-versioning.patch b/dev-python/dynd-python/files/dynd-python-0.6.0-out-of-git-versioning.patch
new file mode 100644
index 000000000000..003091da3e75
--- /dev/null
+++ b/dev-python/dynd-python/files/dynd-python-0.6.0-out-of-git-versioning.patch
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2014-02-10 18:35:07.332899916 -0800
++++ CMakeLists.txt 2014-02-10 18:38:03.220956236 -0800
+@@ -86,8 +86,8 @@
+ endif()
+
+ # Get the git revision
+-get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_PYTHON_GIT_SHA1)
+-git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_PYTHON_VERSION_STRING --dirty --match "v[0-9]*")
++set(DYND_PYTHON_GIT_SHA1 "2eaece194769aa55b505274692bfaafa4ef68ac6")
++set(DYND_PYTHON_VERSION_STRING "v0.6.0")
+ message(STATUS "DyND-Python version: ${DYND_PYTHON_VERSION_STRING}")
+ configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/git_version.cpp.in"
diff --git a/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch b/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
new file mode 100644
index 000000000000..29c3541b3274
--- /dev/null
+++ b/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2014-05-12 14:00:52.000000000 +0400
++++ CMakeLists.txt 2014-05-12 14:03:39.000000000 +0400
+@@ -86,8 +86,9 @@
+ endif()
+
+ # Get the git revision
+-get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_PYTHON_GIT_SHA1)
+-git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_PYTHON_VERSION_STRING --dirty --always --match "v*")
++SET(DYND_PYTHON_GIT_SHA1 "@DYND_PYTHON_GIT_SHA1@")
++SET(DYND_PYTHON_VERSION_STRING "@DYND_PYTHON_VERSION@")
++
+ message(STATUS "DyND-Python version: ${DYND_PYTHON_VERSION_STRING}")
+ configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/git_version.cpp.in"
diff --git a/dev-python/dynd-python/metadata.xml b/dev-python/dynd-python/metadata.xml
new file mode 100644
index 000000000000..3de4fa343928
--- /dev/null
+++ b/dev-python/dynd-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>python</herd>
+ <longdescription lang="en">
+ DyND-Python, a component of the Blaze project, is the Python
+ exposure of the DyND dynamic multi-dimensional array library.
+</longdescription>
+ <upstream>
+ <remote-id type="github">ContinuumIO/dynd-python</remote-id>
+ </upstream>
+</pkgmetadata>