summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-27 08:58:45 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-27 09:00:05 +0200
commit471e96431ec6a3503a87cae2aa1459b48001d818 (patch)
tree9c30df89856c2078f34583340026ff00a441adad /dev-python/ed25519ll/ed25519ll-0.6.ebuild
parentdev-python/mmh3: Bump to 2.5.1 (diff)
downloadgentoo-471e96431ec6a3503a87cae2aa1459b48001d818.tar.gz
gentoo-471e96431ec6a3503a87cae2aa1459b48001d818.tar.bz2
gentoo-471e96431ec6a3503a87cae2aa1459b48001d818.zip
dev-python/ed25519ll: Remove Python 3
The package has *syntax errors* in *source*. This means it will not work in Python 3. So how about we remove Python 3 instead of restricting tests that uncover the failure and pretending things are fine?
Diffstat (limited to 'dev-python/ed25519ll/ed25519ll-0.6.ebuild')
-rw-r--r--dev-python/ed25519ll/ed25519ll-0.6.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/dev-python/ed25519ll/ed25519ll-0.6.ebuild b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
index fa9f433afbb3..b55559e763e1 100644
--- a/dev-python/ed25519ll/ed25519ll-0.6.ebuild
+++ b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
@@ -23,9 +23,6 @@ DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
)"
-# https://bitbucket.org/dholth/ed25519ll/issues/1/testfailures-with-python-3
-RESTRICT=test
-
python_test() {
esetup.py test
}