summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-16 15:35:50 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-16 17:35:08 +0200
commit27d9b6b0cdb1da4c5408994a475174823b7c6d5f (patch)
treeecfbe91885982e373cf29e5dc75a80863dcab543 /dev-python/editdistance-s
parentdev-python/cfgv: new package (diff)
downloadgentoo-27d9b6b0cdb1da4c5408994a475174823b7c6d5f.tar.gz
gentoo-27d9b6b0cdb1da4c5408994a475174823b7c6d5f.tar.bz2
gentoo-27d9b6b0cdb1da4c5408994a475174823b7c6d5f.zip
dev-python/editdistance-s: new package
Second-order dependency of pre-commit. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/editdistance-s')
-rw-r--r--dev-python/editdistance-s/Manifest1
-rw-r--r--dev-python/editdistance-s/editdistance-s-1.0.0.ebuild21
-rw-r--r--dev-python/editdistance-s/metadata.xml20
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/editdistance-s/Manifest b/dev-python/editdistance-s/Manifest
new file mode 100644
index 000000000000..46fd7e954132
--- /dev/null
+++ b/dev-python/editdistance-s/Manifest
@@ -0,0 +1 @@
+DIST editdistance-s-1.0.0.tar.gz 5408 BLAKE2B 5420dff814de4d61f7c36c88113c568562a174205d8a4ff2b52b60e797f7459d95fd2a909b70911cfd7d0d67096a3844888bb88866980a2c43f8967a96ef4c55 SHA512 148234a38f54f70a2d6bc64f6a166a8954c79fb89d5f5c0bf3f041fe60056332901484a0626e218a72ae992f476305cbb662dfa0acdda794727fc682c569d718
diff --git a/dev-python/editdistance-s/editdistance-s-1.0.0.ebuild b/dev-python/editdistance-s/editdistance-s-1.0.0.ebuild
new file mode 100644
index 000000000000..bdbb49dbf8ef
--- /dev/null
+++ b/dev-python/editdistance-s/editdistance-s-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast implementation of edit (Levenshtein) distance"
+HOMEPAGE="https://github.com/asottile/editdistance-s"
+SRC_URI="https://github.com/asottile/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
diff --git a/dev-python/editdistance-s/metadata.xml b/dev-python/editdistance-s/metadata.xml
new file mode 100644
index 000000000000..4bb618ca7155
--- /dev/null
+++ b/dev-python/editdistance-s/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ This is a fork of "editdistance" with the following changes:
+ * __hash__ based support is removed as it makes incorrect assumptions
+ * only strings (type str) are supported
+ * cffi replaces cython (so abi3 wheels can be produced)
+ * the module is renamed to editdistance_s
+ * the public api does not contain eval() (only distance())
+ </longdescription>
+ <upstream>
+ <remote-id type="github">asottile/editdistance-s</remote-id>
+ <remote-id type="pypi">editdistance-s</remote-id>
+ </upstream>
+</pkgmetadata>