summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild')
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
new file mode 100644
index 000000000000..c8c0c60688d0
--- /dev/null
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="eGenix utils for Python"
+HOMEPAGE="http://www.egenix.com/products/python/mxBase http://pypi.python.org/pypi/egenix-mx-base"
+SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
+
+LICENSE="eGenixPublic-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# distutils.command.config writes to CWD, bug #450516
+# mxSetup.py is broken with --build-lib
+#DISTUTILS_IN_SOURCE_BUILD=1
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_prepare_all() {
+ # Don't install documentation in site-packages directories.
+ sed -e "/\.pdf/d" -i egenix_mx_base.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local t
+
+ while IFS= read -r -d '' t
+ do
+ "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
+ done < <(find -name test.py -print0)
+}
+
+python_install() {
+ local f dest=${D}$(python_get_includedir)/mx
+
+ distutils-r1_python_install \
+ build --build-platlib "${BUILD_DIR}"/lib
+
+ mkdir -p "${dest}" || die
+ while IFS= read -r -d '' f
+ do
+ mv -f "${f}" "${dest}" || die
+ done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
+}
+
+python_install_all() {
+ local f
+
+ distutils-r1_python_install_all
+
+ dohtml -a html -r mx
+ while IFS= read -r -d '' f
+ do
+ dodoc "${f}"
+ done < <(find -name '*.pdf' -print0)
+}