summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-15 13:09:49 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-15 13:09:49 +0000
commite2441d0bd5a8a0aebea0b7bae488f4bafb850acc (patch)
treef9cbf3d5211dacc99964bfd1083063478191ca3f /dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild
parentMerge remote-tracking branch 'github/pr/857'. (diff)
downloadgentoo-e2441d0bd5a8a0aebea0b7bae488f4bafb850acc.tar.gz
gentoo-e2441d0bd5a8a0aebea0b7bae488f4bafb850acc.tar.bz2
gentoo-e2441d0bd5a8a0aebea0b7bae488f4bafb850acc.zip
dev-python/elasticsearch-curator: Use Bash syntax. Add missing die.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild')
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild
index 9dbbb26e78d5..6e46527e3141 100644
--- a/dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild
+++ b/dev-python/elasticsearch-curator/elasticsearch-curator-3.4.0.ebuild
@@ -56,7 +56,7 @@ python_test() {
# start local instance of elasticsearch
${ES}/bin/elasticsearch -d -p ${PID}
- for i in `seq 10`; do
+ for i in {1..10}; do
grep -q "started" ${ES_LOG} 2> /dev/null
if [ $? -eq 0 ]; then
einfo "Elasticsearch started"
@@ -75,7 +75,7 @@ python_test() {
done
export TEST_ES_SERVER="localhost:${ES_PORT}"
- esetup.py test
+ esetup.py test || die
pkill -F ${PID}
}