summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-02-14 14:27:47 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-14 22:54:58 +0100
commit7fb1874fe2cd8ee139132a5a883be5b9042dea8b (patch)
tree4e4336c8cca1f5426e5e4869d19a7e21424bc8cc /dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild
parentxfce-extra/thunar-media-tags-plugin: Bump to 0.3.0 (GTK+3 port) (diff)
downloadgentoo-7fb1874fe2cd8ee139132a5a883be5b9042dea8b.tar.gz
gentoo-7fb1874fe2cd8ee139132a5a883be5b9042dea8b.tar.bz2
gentoo-7fb1874fe2cd8ee139132a5a883be5b9042dea8b.zip
dev-python/elasticsearch-py: improve ebuild
Bug: https://bugs.gentoo.org/643684 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild')
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild
index 3010af4f0e28..db922834ad26 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-6.0.0.ebuild
@@ -4,17 +4,11 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-ES_VERSION="6.0.0"
+ES_VERSION="6.0.1"
inherit distutils-r1
-# tests fail in chroot
-# https://github.com/elastic/elasticsearch/issues/12018
-RESTRICT="test"
-
MY_PN=${PN/-py/}
-
DESCRIPTION="official Python low-level client for Elasticsearch"
HOMEPAGE="https://github.com/elastic/elasticsearch-py"
SRC_URI="https://github.com/elasticsearch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
@@ -25,6 +19,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples doc test"
+# tests fail in chroot
+# https://github.com/elastic/elasticsearch/issues/12018
+RESTRICT="test"
+
RDEPEND=">=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
<dev-python/urllib3-1.23[${PYTHON_USEDEP}]"
@@ -40,6 +38,17 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/nosexcover[${PYTHON_USEDEP}]
virtual/jre:1.8 )"
+python_prepare_all() {
+ # 643684
+ sed -i -e /urllib3/d setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C docs -j1 man $(usex doc html "")
+}
+
# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-py
python_test() {
ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
@@ -85,10 +94,6 @@ python_test() {
pkill -F ${PID}
}
-python_compile_all() {
- emake -C docs -j1 man $(usex doc html "")
-}
-
python_install_all() {
use doc && HTML_DOCS=( docs/_build/html/. )
use examples && dodoc -r example