summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-23 09:58:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-23 12:48:57 +0100
commit909cff76a8ed09f61f9756d878a800b6fe406da7 (patch)
treef7e661e43e8e2be7a7a8d8319620e206e525d0c7 /dev-python/elementpath/elementpath-2.1.2.ebuild
parentprofiles/prefix/use.mask: drop obsolete ruby23 mask (diff)
downloadgentoo-909cff76a8ed09f61f9756d878a800b6fe406da7.tar.gz
gentoo-909cff76a8ed09f61f9756d878a800b6fe406da7.tar.bz2
gentoo-909cff76a8ed09f61f9756d878a800b6fe406da7.zip
dev-python/elementpath: Bump to 2.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath/elementpath-2.1.2.ebuild')
-rw-r--r--dev-python/elementpath/elementpath-2.1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/elementpath/elementpath-2.1.2.ebuild b/dev-python/elementpath/elementpath-2.1.2.ebuild
new file mode 100644
index 000000000000..73b63d2a6ee3
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest