summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-17 21:29:31 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-17 22:51:11 +0200
commita43cdc609ccb8d8b88512acc8a147ecc87be70da (patch)
tree7f890486b034208f824b6846c31921b183302230 /dev-python/embedly/embedly-0.5.0-r1.ebuild
parentdev-python/timelib: Disable python3* (diff)
downloadgentoo-a43cdc609ccb8d8b88512acc8a147ecc87be70da.tar.gz
gentoo-a43cdc609ccb8d8b88512acc8a147ecc87be70da.tar.bz2
gentoo-a43cdc609ccb8d8b88512acc8a147ecc87be70da.zip
dev-python/embedly: Fix dependencies
Diffstat (limited to 'dev-python/embedly/embedly-0.5.0-r1.ebuild')
-rw-r--r--dev-python/embedly/embedly-0.5.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/embedly/embedly-0.5.0-r1.ebuild b/dev-python/embedly/embedly-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..e26065a3f353
--- /dev/null
+++ b/dev-python/embedly/embedly-0.5.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Embedly"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Library for Embedly"
+HOMEPAGE="https://github.com/embedly/embedly-python/ https://pypi.python.org/pypi/Embedly"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+# Testsuite relies upon connection to various sites on the net