summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-26 17:49:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-26 17:49:15 +0100
commitd31dc3a0e42203e1e0892eddd7429457e635dd7c (patch)
treed9f329cfd5cd1beba20087bf9b1be5afa0edd1b7 /dev-python/emoji/emoji-2.11.0.ebuild
parentdev-python/nh3: Bump to 0.2.17 (diff)
downloadgentoo-d31dc3a0e42203e1e0892eddd7429457e635dd7c.tar.gz
gentoo-d31dc3a0e42203e1e0892eddd7429457e635dd7c.tar.bz2
gentoo-d31dc3a0e42203e1e0892eddd7429457e635dd7c.zip
dev-python/emoji: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/emoji/emoji-2.11.0.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.11.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.11.0.ebuild b/dev-python/emoji/emoji-2.11.0.ebuild
new file mode 100644
index 000000000000..e71c124e54b5
--- /dev/null
+++ b/dev-python/emoji/emoji-2.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest