summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-17 09:59:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-17 10:36:09 +0200
commit7c60eb994fbc37252b3a6821ae805cefb2575b37 (patch)
tree59e6097734c7dbe45f979035f3dbb19d60e90234 /dev-python/emoji/emoji-2.8.0.ebuild
parentdev-python/ansible-compat: Bump to 4.1.6 (diff)
downloadgentoo-7c60eb994fbc37252b3a6821ae805cefb2575b37.tar.gz
gentoo-7c60eb994fbc37252b3a6821ae805cefb2575b37.tar.bz2
gentoo-7c60eb994fbc37252b3a6821ae805cefb2575b37.zip
dev-python/emoji: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/emoji/emoji-2.8.0.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.8.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.8.0.ebuild b/dev-python/emoji/emoji-2.8.0.ebuild
new file mode 100644
index 000000000000..9cf0bc5fde70
--- /dev/null
+++ b/dev-python/emoji/emoji-2.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest