summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-31 09:37:38 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-31 09:37:54 +0100
commit1c689827cddff915f65f0e6c289d97642a753a68 (patch)
tree5d762334e7ffdec473ef016abcb03df383118f9d /dev-python/enable/files
parentmedia-libs/opencv: contrib updated, broken example removed bug #558104. (diff)
downloadgentoo-1c689827cddff915f65f0e6c289d97642a753a68.tar.gz
gentoo-1c689827cddff915f65f0e6c289d97642a753a68.tar.bz2
gentoo-1c689827cddff915f65f0e6c289d97642a753a68.zip
dev-python/enable: Backport fixes for doc building
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564510 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/enable/files')
-rw-r--r--dev-python/enable/files/enable-4.5.1-doc.patch24
-rw-r--r--dev-python/enable/files/enable-4.5.1-version.patch31
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/enable/files/enable-4.5.1-doc.patch b/dev-python/enable/files/enable-4.5.1-doc.patch
new file mode 100644
index 000000000000..c9cc1ff2e3cc
--- /dev/null
+++ b/dev-python/enable/files/enable-4.5.1-doc.patch
@@ -0,0 +1,24 @@
+From 41134b03b96b741d95554846841c189313052265 Mon Sep 17 00:00:00 2001
+From: John Wiggins <jwiggins@enthought.com>
+Date: Thu, 1 Oct 2015 20:40:07 +0200
+Subject: [PATCH] Read the docs version directly from enable._version
+
+---
+ docs/source/conf.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/docs/source/conf.py b/docs/source/conf.py
+index 10b7552..995e315 100644
+--- a/docs/source/conf.py
++++ b/docs/source/conf.py
+@@ -41,8 +41,8 @@
+ # The default replacements for |version| and |release|, also used in various
+ # other places throughout the built documents.
+ d = {}
+-execfile(os.path.join('..', '..', 'enable', '__init__.py'), d)
+-version = release = d['__version__']
++execfile(os.path.join('..', '..', 'enable', '_version.py'), d)
++version = release = d['full_version']
+
+ # There are two options for replacing |today|: either, you set today to some
+ # non-false value, then it is used:
diff --git a/dev-python/enable/files/enable-4.5.1-version.patch b/dev-python/enable/files/enable-4.5.1-version.patch
new file mode 100644
index 000000000000..1dd3fe42775e
--- /dev/null
+++ b/dev-python/enable/files/enable-4.5.1-version.patch
@@ -0,0 +1,31 @@
+From f91c824ebad74e8c23e62fe3390842c5fe322aee Mon Sep 17 00:00:00 2001
+From: itziakos <ioannist@enthought.com>
+Date: Wed, 20 May 2015 22:52:42 +0100
+Subject: [PATCH] check the enable._version.py when installing from source
+
+---
+ setup.py | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index f765f51..3328b93 100644
+--- a/setup.py
++++ b/setup.py
+@@ -92,13 +92,14 @@ def write_version_py(filename):
+ fullversion = VERSION
+ if os.path.exists('.git'):
+ git_revision, dev_num = git_version()
+- elif os.path.exists('kiva/_version.py'):
++ # All packages are synced with the enable version
++ elif os.path.exists('enable/_version.py'):
+ # must be a source distribution, use existing version file
+ try:
+- from kiva._version import git_revision, full_version
++ from enable._version import git_revision, full_version
+ except ImportError:
+ raise ImportError("Unable to import git_revision. Try removing "
+- "kiva/_version.py and the build directory "
++ "enable/_version.py and the build directory "
+ "before building.")
+
+ match = re.match(r'.*?\.dev(?P<dev_num>\d+)', full_version)