summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 18:09:28 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 18:09:44 +0200
commite3a0d23f4ad40c56ab64367c541a368ce145c3ae (patch)
treed035629cfa397d6fc32b6ce05913a877b7e1fb16 /dev-python/enable
parentapp-emulation/libvirt: drop 1.2.15-r1 (diff)
downloadgentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.tar.gz
gentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.tar.bz2
gentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.zip
dev-python/enable: Add support for gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561836 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/enable-4.5.1.ebuild5
-rw-r--r--dev-python/enable/files/enable-4.5.1-gcc-5.patch22
-rw-r--r--dev-python/enable/metadata.xml2
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/enable/enable-4.5.1.ebuild b/dev-python/enable/enable-4.5.1.ebuild
index 31a0a802c754..300c03c337aa 100644
--- a/dev-python/enable/enable-4.5.1.ebuild
+++ b/dev-python/enable/enable-4.5.1.ebuild
@@ -41,7 +41,10 @@ DEPEND="${RDEPEND}
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${PN}-4.4.1-swig.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.1-swig.patch
+ "${FILESDIR}"/${P}-gcc-5.patch
+ )
python_prepare_all() {
append-cflags -fno-strict-aliasing
diff --git a/dev-python/enable/files/enable-4.5.1-gcc-5.patch b/dev-python/enable/files/enable-4.5.1-gcc-5.patch
new file mode 100644
index 000000000000..b18b8eae7bb7
--- /dev/null
+++ b/dev-python/enable/files/enable-4.5.1-gcc-5.patch
@@ -0,0 +1,22 @@
+From 55a74ccfc33764499497022dd3649be4bb1091ed Mon Sep 17 00:00:00 2001
+From: Nathan Ringo <tikiking1@users.noreply.github.com>
+Date: Wed, 10 Jun 2015 22:06:57 -0500
+Subject: [PATCH] Fixes #200
+
+---
+ kiva/agg/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kiva/agg/setup.py b/kiva/agg/setup.py
+index 5b4d458..c6e290a 100644
+--- a/kiva/agg/setup.py
++++ b/kiva/agg/setup.py
+@@ -170,7 +170,7 @@ def get_ft2_sources((lib_name, build_info), build_dir):
+ f = os.popen("g++ --version")
+ line0 = f.readline()
+ f.close()
+- m = re.match(r'.+?\s(3|4)\.\d+', line0)
++ m = re.match(r'.+?\s([3-5])\.\d+', line0)
+ if int(m.group(1)) < 4:
+ use_32bit_workaround = True
+
diff --git a/dev-python/enable/metadata.xml b/dev-python/enable/metadata.xml
index de31ed9814dd..aee10049a76c 100644
--- a/dev-python/enable/metadata.xml
+++ b/dev-python/enable/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>