summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 06:19:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 06:19:58 +0200
commitce6d1bc94a05b3aebf9d79c71b2f360f1d7677a2 (patch)
tree21f3e37fba15cadba3c498fe03817ad0e3295c18 /dev-python/ensurepip-setuptools/ensurepip-setuptools-67.7.0.ebuild
parentdev-python/setuptools: Bump to 67.7.0 (diff)
downloadgentoo-ce6d1bc94a05b3aebf9d79c71b2f360f1d7677a2.tar.gz
gentoo-ce6d1bc94a05b3aebf9d79c71b2f360f1d7677a2.tar.bz2
gentoo-ce6d1bc94a05b3aebf9d79c71b2f360f1d7677a2.zip
dev-python/ensurepip-setuptools: Bump to 67.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-setuptools/ensurepip-setuptools-67.7.0.ebuild')
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-67.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-67.7.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-67.7.0.ebuild
new file mode 100644
index 000000000000..c13c3370cbbe
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-67.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}