summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-19 08:04:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-19 08:44:40 +0200
commit8f9d5c72ccea5e6b2b7e8e7d4685ca6859cd03b9 (patch)
tree60986feafb7e8e5a9256921656539f9bdcbfbc13 /dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
parentdev-python/sphinx-gallery: Bump to 0.14.0 (diff)
downloadgentoo-8f9d5c72ccea5e6b2b7e8e7d4685ca6859cd03b9.tar.gz
gentoo-8f9d5c72ccea5e6b2b7e8e7d4685ca6859cd03b9.tar.bz2
gentoo-8f9d5c72ccea5e6b2b7e8e7d4685ca6859cd03b9.zip
dev-python/ensurepip-setuptools: Bump to 68.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild')
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
new file mode 100644
index 000000000000..8346a1bd0f6d
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}