summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:14:10 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:54:57 +0300
commitd9e4a54b10d85d880b7889ca8d9c97cc169d0b56 (patch)
tree7c324f471b242027082c6e3b80db1fd420103ccf /dev-python/ensurepip-wheels
parentdev-python/identify: add 2.5.3 (diff)
downloadgentoo-d9e4a54b10d85d880b7889ca8d9c97cc169d0b56.tar.gz
gentoo-d9e4a54b10d85d880b7889ca8d9c97cc169d0b56.tar.bz2
gentoo-d9e4a54b10d85d880b7889ca8d9c97cc169d0b56.zip
dev-python/ensurepip-wheels: add 63.4.1.22.2.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-wheels')
-rw-r--r--dev-python/ensurepip-wheels/Manifest2
-rw-r--r--dev-python/ensurepip-wheels/ensurepip-wheels-63.4.1.22.2.2.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/ensurepip-wheels/Manifest b/dev-python/ensurepip-wheels/Manifest
index b2bdf913b1c4..7ba246d840b9 100644
--- a/dev-python/ensurepip-wheels/Manifest
+++ b/dev-python/ensurepip-wheels/Manifest
@@ -1,2 +1,4 @@
DIST pip-22.2.1-py3-none-any.whl 2044666 BLAKE2B 702699d059273182f248acb48f6f6c9ec287e2edb3de2c84c05402b4fc82da23c14f76e2d3ed8cc1c281e3c8d8fd1a467963d3b9ab6fa384c16d5057fce1561d SHA512 dad2ce78544502a3ec4492a57acc5c1cf6f34ee1d3200a46cf19246f7eda701524d745237909b154317c3d6be6d4e61b086be9562d31d54b60268ca573692638
+DIST pip-22.2.2-py3-none-any.whl 2044706 BLAKE2B 254427e593e44d9f1ce48276fd40f214e8ca9d27b6c31b7a6ed5fa4566df6b1f723215c6a1766a534ce18174f2363c383dbff19368d1b89f1519a53bebd34215 SHA512 142d3144c14b692c645613d98bf35dd91193128d5e21b61a8a702548f1247fac662499d6e39b65c0aa9a0444d2d92983fd8c410439796626485a4e1be99a102f
DIST setuptools-63.3.0-py3-none-any.whl 1228351 BLAKE2B 5a7a8d864b5fc992952a4c7f0230c3ebb6f33c7b4fc965ca8bfa4cf3b57948e8353f59074f7374e3d002866333d3ad5fd072ccd479f8470cbfcd14aa635efc54 SHA512 f2df66493fb9520b50e3e93560b17e5aa6f01e5fde27028a550249beb54f3ea6b2d8f0a2bcc57afaff193e38d5b217544c0623b254ac300652aed444abf06a14
+DIST setuptools-63.4.1-py3-none-any.whl 1228875 BLAKE2B 8f5a91764f509311f217d9cec6030c8318138d2d60bf8e8cf8ab0d7e9a9d578c1f644aaf30988846c4f22b962b10fa47c2e92cf63ffe0186acaf697c8eb96cc9 SHA512 c73f075f80a97d77906ed9acc1850ab4e458c1d4423a3f9a4b71bd677d7bd0e3ea291683942cd2cc9a91d454e905ea9732e169711c5218a8047997049e0c5536
diff --git a/dev-python/ensurepip-wheels/ensurepip-wheels-63.4.1.22.2.2.ebuild b/dev-python/ensurepip-wheels/ensurepip-wheels-63.4.1.22.2.2.ebuild
new file mode 100644
index 000000000000..691136b4b5bb
--- /dev/null
+++ b/dev-python/ensurepip-wheels/ensurepip-wheels-63.4.1.22.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+SETUPTOOLS_WHL=setuptools-$(ver_cut 1-3)-py3-none-any.whl
+PIP_WHL=pip-$(ver_cut 4-)-py3-none-any.whl
+
+DESCRIPTION="Shared wheels for ensurepip Python module"
+HOMEPAGE="
+ https://pypi.org/project/pip/
+ https://pypi.org/project/setuptools/
+"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/p/pip/${PIP_WHL}
+ https://files.pythonhosted.org/packages/py3/s/setuptools/${SETUPTOOLS_WHL}
+"
+S=${DISTDIR}
+
+# combined license of setuptools and pip (with its bundled deps)
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${PIP_WHL}" "${SETUPTOOLS_WHL}"
+}