summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 23:57:46 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 23:59:19 -0800
commitd8139fed060f3b644040dab5142b4325d39cb64f (patch)
tree03b9b80ed2cf7e2ea463460c6065c6473b118b62 /dev-python/entrypoints/entrypoints-0.3-r1.ebuild
parentsys-devel/clang-runtime: Bump to 9.0.1_rc1 (diff)
downloadgentoo-d8139fed060f3b644040dab5142b4325d39cb64f.tar.gz
gentoo-d8139fed060f3b644040dab5142b4325d39cb64f.tar.bz2
gentoo-d8139fed060f3b644040dab5142b4325d39cb64f.zip
dev-python/entrypoints-0.3-r1: Revbump, add py38, drop doc (was broken)
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/entrypoints/entrypoints-0.3-r1.ebuild')
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
new file mode 100644
index 000000000000..3bd5b0bebf10
--- /dev/null
+++ b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.2.1-init.py.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}