summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-16 15:45:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-16 17:56:57 +0200
commit4a09b8e1724fa7c8c43372fdc3e51f74ae412066 (patch)
tree24729f516b838762e6cdac082b692c7921c5af4a /dev-python/entrypoints
parentdev-python/pandocfilters: Drop old (diff)
downloadgentoo-4a09b8e1724fa7c8c43372fdc3e51f74ae412066.tar.gz
gentoo-4a09b8e1724fa7c8c43372fdc3e51f74ae412066.tar.bz2
gentoo-4a09b8e1724fa7c8c43372fdc3e51f74ae412066.zip
dev-python/entrypoints: Drop old
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python/entrypoints')
-rw-r--r--dev-python/entrypoints/Manifest2
-rw-r--r--dev-python/entrypoints/entrypoints-0.2.1.ebuild59
-rw-r--r--dev-python/entrypoints/entrypoints-0.2.2.ebuild56
-rw-r--r--dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch20
-rw-r--r--dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch20
5 files changed, 0 insertions, 157 deletions
diff --git a/dev-python/entrypoints/Manifest b/dev-python/entrypoints/Manifest
index dc84d23fcbd1..3c82fa566540 100644
--- a/dev-python/entrypoints/Manifest
+++ b/dev-python/entrypoints/Manifest
@@ -1,3 +1 @@
-DIST entrypoints-0.2.1.tar.gz 11126 BLAKE2B ec3e0f0c331d4dd982aa8b53335a39181bc5774bc5bb09b5fe61405acec5de62e17c2db9e30c67ddbaf0405f765df1b979111b0fcdfe675a7e981f910f4c2ef6 SHA512 67a24fc53ae8bdac6bda163d2c8057b158979d55ccdbcdb8709966573bf0a999728e04eb92a05fbc2c0d532593de0ec6518bcfed1d5bcf875b00bbd5c48494c7
-DIST entrypoints-0.2.2.tar.gz 11162 BLAKE2B a73ed713f5653d8f4d9c742b8ecd8990c5b37751c97afacde8cebfa0c4c3654154aa9db90b09a629145d4a695ab933ffa1ebd83bc64f74de47e75651d2dfdd47 SHA512 c987807924f92fd6bc0aab1cccaa4b204587d4f34932c353033ed062fff5adf69bfdc8767f095dda15fff9b57e2be2d205bfa44abc5ad7f7820114e0355a6e99
DIST entrypoints-0.2.3.tar.gz 11219 BLAKE2B ae7745a075d564b3cc25a0580ae9f30f6e1a0b4bca7315c4fc3700408e4ab3762831212a451eb937ab94096d1db5c1478980b216dea7cfb95a8577d6337534a0 SHA512 dbf8085652e50cbdbe137ae655ef765cff58bdaa6beefebf1383dcd96dfcbf9c92580c09e9a58de7893aebdd7b2a701ef8d13a56ef0fa9a3d9ef7a5bd1d9b11b
diff --git a/dev-python/entrypoints/entrypoints-0.2.1.ebuild b/dev-python/entrypoints/entrypoints-0.2.1.ebuild
deleted file mode 100644
index 854450116632..000000000000
--- a/dev-python/entrypoints/entrypoints-0.2.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Discover and load entry points from installed packages"
-HOMEPAGE="https://github.com/takluyver/entrypoints"
-SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7)
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
- "${FILESDIR}/${P}"-init.py.patch
-)
-
-python_prepare_all() {
-
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-
- mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
- }
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}
diff --git a/dev-python/entrypoints/entrypoints-0.2.2.ebuild b/dev-python/entrypoints/entrypoints-0.2.2.ebuild
deleted file mode 100644
index 2f1065d5e644..000000000000
--- a/dev-python/entrypoints/entrypoints-0.2.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Discover and load entry points from installed packages"
-HOMEPAGE="https://github.com/takluyver/entrypoints"
-SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
- "${FILESDIR}/${PN}"-0.2.1-init.py.patch
-)
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-
- mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
-}
-
-python_compile_all() {
- if use doc; then
- emake -C doc html
- HTML_DOCS=( doc/_build/html/. )
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch
deleted file mode 100644
index 98786854773c..000000000000
--- a/dev-python/entrypoints/files/entrypoints-0.2.1-setup.py.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-setup.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
-
-Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
---- /dev/null
-+++ b/setup.py
-@@ -0,0 +1,13 @@
-+from distutils.core import setup
-+
-+setup(name='entrypoints',
-+ version='0.2.1',
-+ description='Discover and load entry points from installed packages.',
-+ author='Thomas Kluyver',
-+ author_email='thomas@kluyver.me.uk',
-+ url='https://github.com/takluyver/entrypoints',
-+ packages=['entrypoints'],
-+ classifiers=[
-+ 'License :: OSI Approved :: MIT License'
-+ ]
-+)
-\ No newline at end of file
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch
deleted file mode 100644
index bb82eee6951f..000000000000
--- a/dev-python/entrypoints/files/entrypoints-0.2.2-setup.py.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-setup.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
-
-Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
---- /dev/null
-+++ b/setup.py
-@@ -0,0 +1,13 @@
-+from distutils.core import setup
-+
-+setup(name='entrypoints',
-+ version='0.2.2',
-+ description='Discover and load entry points from installed packages.',
-+ author='Thomas Kluyver',
-+ author_email='thomas@kluyver.me.uk',
-+ url='https://github.com/takluyver/entrypoints',
-+ packages=['entrypoints'],
-+ classifiers=[
-+ 'License :: OSI Approved :: MIT License'
-+ ]
-+)
-\ No newline at end of file