summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/errorhandler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/errorhandler')
-rw-r--r--dev-python/errorhandler/Manifest1
-rw-r--r--dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild50
-rw-r--r--dev-python/errorhandler/files/docs.patch12
-rw-r--r--dev-python/errorhandler/files/errorhandler-1.1.1-test.patch9
-rw-r--r--dev-python/errorhandler/metadata.xml12
5 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/errorhandler/Manifest b/dev-python/errorhandler/Manifest
new file mode 100644
index 000000000000..38b3f945bbb8
--- /dev/null
+++ b/dev-python/errorhandler/Manifest
@@ -0,0 +1 @@
+DIST errorhandler-1.1.1.tar.gz 8321 SHA256 2baa97a8a256fe72960d196bbdee4404162186f539c4d73b3f1c072db18463e9 SHA512 a2f875537103086be956becfdac25a43a646a89b404b6a7a2a243c6d2ddbc29d55948b781529d0a0fa82b163187747f3396b62ed0be98d39834de038cc4a1fd2 WHIRLPOOL dd296200b2a451ae36225122d69e215e463a777ca162ed4b98067e146080e5fa91fd4ee8a219fc0999a05461aa69c712866e57c3b31c9a19366d82ea8efdad8a
diff --git a/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild b/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..5c40874590c1
--- /dev/null
+++ b/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Logging framework handler that tracks when messages above a certain level have been logged"
+HOMEPAGE="http://pypi.python.org/pypi/errorhandler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/docs.patch
+)
+
+python_prepare_all() {
+ sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -c "import errorhandler.tests as et, unittest; \
+ unittest.TextTestRunner().run(et.test_suite())" \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/errorhandler/files/docs.patch b/dev-python/errorhandler/files/docs.patch
new file mode 100644
index 000000000000..10c704d6fec3
--- /dev/null
+++ b/dev-python/errorhandler/files/docs.patch
@@ -0,0 +1,12 @@
+diff -ur errorhandler-1.1.1.orig/docs/conf.py errorhandler-1.1.1/docs/conf.py
+--- docs/conf.py 2009-11-07 20:08:10.000000000 +0800
++++ docs/conf.py 2013-06-07 14:05:17.321475285 +0800
+@@ -8,8 +8,6 @@
+ 'sphinx.ext.intersphinx'
+ ]
+
+-intersphinx_mapping = {'http://docs.python.org/dev': None}
+-
+ # General
+ source_suffix = '.txt'
+ master_doc = 'index'
diff --git a/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch b/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch
new file mode 100644
index 000000000000..126b508b9923
--- /dev/null
+++ b/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch
@@ -0,0 +1,9 @@
+diff -ur errorhandler-1.1.1.orig/errorhandler/tests.py errorhandler-1.1.1/errorhandler/tests.py
+--- errorhandler/tests.py 2010-03-01 16:41:46.000000000 +0800
++++ errorhandler/tests.py 2012-04-26 02:28:11.991954681 +0800
+@@ -134,3 +134,5 @@
+ tearDown=tearDown,
+ optionflags=options),
+ ))
++if __name__ == "__main__":
++ unittest.main()
diff --git a/dev-python/errorhandler/metadata.xml b/dev-python/errorhandler/metadata.xml
new file mode 100644
index 000000000000..917f28e01575
--- /dev/null
+++ b/dev-python/errorhandler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">errorhandler</remote-id>
+ </upstream>
+</pkgmetadata>