summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/etsproxy/etsproxy-0.1.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/etsproxy/etsproxy-0.1.2-r1.ebuild')
-rw-r--r--dev-python/etsproxy/etsproxy-0.1.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/etsproxy/etsproxy-0.1.2-r1.ebuild b/dev-python/etsproxy/etsproxy-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..30df6d955579
--- /dev/null
+++ b/dev-python/etsproxy/etsproxy-0.1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: Proxy modules for backwards compatibility"
+HOMEPAGE="http://pypi.python.org/pypi/etsproxy"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!<dev-python/apptools-4
+ !<dev-python/blockcanvas-4
+ !<dev-python/chaco-4
+ !<dev-python/codetools-4
+ !<dev-python/enable-4
+ !<dev-python/enthoughtbase-4
+ !<dev-python/envisagecore-4
+ !<dev-python/envisageplugins-4
+ !<dev-python/etsdevtools-4
+ !<dev-python/etsprojecttools-4
+ !<dev-python/graphcanvas-4
+ !<sci-visualization/mayavi-4
+ !<dev-python/scimath-4
+ !<dev-python/traits-4
+ !<dev-python/traitsbackendwx-4
+ !<dev-python/traitsbackendqt-4
+ !<dev-python/traitsgui-4"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"