summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-09 08:52:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:22:52 +0300
commit5aaf88d9e518fe2a5dbb0509590b64028a601ba8 (patch)
tree44d04cf3d5a6e13bb77926204010f3874a32b4b0 /dev-python/etuples
parentdev-python/croniter: add 1.3.7 (diff)
downloadgentoo-5aaf88d9e518fe2a5dbb0509590b64028a601ba8.tar.gz
gentoo-5aaf88d9e518fe2a5dbb0509590b64028a601ba8.tar.bz2
gentoo-5aaf88d9e518fe2a5dbb0509590b64028a601ba8.zip
dev-python/etuples: add 0.3.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/etuples')
-rw-r--r--dev-python/etuples/Manifest1
-rw-r--r--dev-python/etuples/etuples-0.3.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/etuples/Manifest b/dev-python/etuples/Manifest
index 82ad79bc7fed..b082a149babf 100644
--- a/dev-python/etuples/Manifest
+++ b/dev-python/etuples/Manifest
@@ -1,3 +1,4 @@
DIST etuples-0.3.5.gh.tar.gz 44924 BLAKE2B 81b603c851b89b3ec3556246d7dfc12a533632f4e99f8b784c4b9f46c3ee51fe7d370556e376a957e52c980b6e16fc93d85c597d31cee371fa2e5cbeec962c9e SHA512 df51ff42609a341c42009b650dadac2a6fb8ea85c3ccc6145ee2bdf6270ed9509d73196f8b0b789091918e93492f766d5fc242e2d5acc30074c171a2334a42fa
DIST etuples-0.3.6.gh.tar.gz 45115 BLAKE2B 5fc88a46433d8074e019f97de1845732ce088e08098f8fd72b9ad0af2d869420805f753cd4a70c24f309d37115a36d9a634c8d3a1837506f781e4b6771e8cee8 SHA512 285d56c291f765c5364a53c7746bdab8aaad71bdc40607f10f0fb9570f22c66352737ba0543d447d83ecc60f7cdfd4e7b406efea7ff9b15d72818f31a10ba4e9
DIST etuples-0.3.7.gh.tar.gz 45284 BLAKE2B 91766826e779af719437eb50e83c6664d2aab244c36067c30a7c21145d771c1ba86e4853625033caec45c633bd9f7e3d62ba750eb0c9f3cfc1d095cc25c01680 SHA512 e829e763b14fe850ea77aec922be1735debb14214f9c1bb9a033fd31c11296e518f98dacccba5f9c279affa2f1d2eb5c053b0704ccb79f45c08167da684e3aef
+DIST etuples-0.3.8.gh.tar.gz 45301 BLAKE2B 56fdae84b180b9ab5a81533d4028d8271e443146a4ed456252ca15400a2afb9987c741c5e5155b9ed48eb12bcc6038e081913c49e00b4eaf67a69c52b2a981c5 SHA512 0971baa9c3038ce1bf9974b750f9e642ecaad92c59b12bc69a2beb6cf4b042302580d96d0feae80a280634f56371f681fc1efcf48741a7cd65b35d9a77b66930
diff --git a/dev-python/etuples/etuples-0.3.8.ebuild b/dev-python/etuples/etuples-0.3.8.ebuild
new file mode 100644
index 000000000000..bf565f12b12c
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest