summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 15:05:22 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 23:13:06 +0100
commit5eaced362e79a757c6e821fab47058e43bc0b4ee (patch)
treeb44a2bc1f08b492c7a1f38628300fe05275791ef /dev-python/eventlet
parentdev-python/dulwich: Clean old up (diff)
downloadgentoo-5eaced362e79a757c6e821fab47058e43bc0b4ee.tar.gz
gentoo-5eaced362e79a757c6e821fab47058e43bc0b4ee.tar.bz2
gentoo-5eaced362e79a757c6e821fab47058e43bc0b4ee.zip
dev-python/eventlet: Clean old up
Diffstat (limited to 'dev-python/eventlet')
-rw-r--r--dev-python/eventlet/Manifest2
-rw-r--r--dev-python/eventlet/eventlet-0.18.4.ebuild63
-rw-r--r--dev-python/eventlet/eventlet-0.20.0-r1.ebuild67
3 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/eventlet/Manifest b/dev-python/eventlet/Manifest
index 1c757a05afdc..4147e6960b7f 100644
--- a/dev-python/eventlet/Manifest
+++ b/dev-python/eventlet/Manifest
@@ -1,4 +1,2 @@
-DIST eventlet-0.18.4.tar.gz 288920 BLAKE2B 497b5e154de495049e477ab54660fa4e5af978c5a2d4a8faa566a965ccbbc017aaf9fc14df6e763191ad2daac70c859b935bce6cc73c6c097bcadd507d738f55 SHA512 3098f2e8649b1e10157b9474571b372176b05263a7d5e7bb915b0464551d70505bbdf77dc072f64c1c05b3011406ae4814ea1b6f746cea766bb58827b1515fcc
-DIST eventlet-0.20.0.tar.gz 466828 BLAKE2B 43beb8f924c5e375a554db3fb90e3c39121ff9899aa1a214118531e3e6fa7711899f278b2187e1e61409a58c05e9bba1a8a6392e1b31a811ef1f32dd7b929016 SHA512 4be70ba8cc3ac76d424aad66cd214e97249a42785319b992d048a77cd26f53a428f7959596d07da9a88c92ee103d73d4990733fc00bca57cc8fd242041365348
DIST eventlet-0.20.1.tar.gz 469509 BLAKE2B 727844b70c4e1874a58efc95551dd7f12bec1c8d01cadeaedbc49f00a86e1393b690076fe720e8efdf00107f72b892a3a1f4c4921f95656b904221e748df7f09 SHA512 875c1ca82822a486bf28866c7d1f34df2419e7d33450a21740434d2e7f15c37a1090436cb7fe1feaeb5c810d39e4b238206c502323317897c8a42e844cbe7734
DIST eventlet-0.21.0.tar.gz 484191 BLAKE2B 07d3f5d1dca11032d51fef9ceb624e07da9e93bed914233da9abbdff27f21f2482b9e3417b50a63f383cae13615c6a781104a05dfb66f28d6ab4e469bce06ef9 SHA512 4ee682ca8faf870ff6f1d72e93527028f73ae13d7f755eceafb23f3cde48e52b83ff04b645b7e90299997713de93c52f244db8b81d6abc7788a56ea38c7b0f47
diff --git a/dev-python/eventlet/eventlet-0.18.4.ebuild b/dev-python/eventlet/eventlet-0.18.4.ebuild
deleted file mode 100644
index 4b00621ad223..000000000000
--- a/dev-python/eventlet/eventlet-0.18.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.python.org/pypi/eventlet https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/python-docs-2.7.6-r1:2.7 )
- test? ( ${RDEPEND}
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
- fi
-
- if use test; then
-# sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-# sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-# sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
- sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
- fi
-
- # Prevent file collisions from teestsuite
- sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # https://github.com/eventlet/eventlet/issues/152
- use doc && emake -C doc html
-}
-
-python_test() {
- # Several errors 1 failure
- # https://github.com/eventlet/eventlet/issues/151
- nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.20.0-r1.ebuild b/dev-python/eventlet/eventlet-0.20.0-r1.ebuild
deleted file mode 100644
index b0366da9f319..000000000000
--- a/dev-python/eventlet/eventlet-0.20.0-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.python.org/pypi/eventlet https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="virtual/python-enum34
- >=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/python-docs-2.7.6-r1:2.7 )
- test? ( ${RDEPEND}
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # provided by virtual/python-enum34
- sed -i '/enum-compat/d' setup.py || die
-
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
- fi
-
- if use test; then
-# sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-# sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-# sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
- sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
- fi
-
- # Prevent file collisions from teestsuite
- sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # https://github.com/eventlet/eventlet/issues/152
- use doc && emake -C doc html
-}
-
-python_test() {
- # Several errors 1 failure
- # https://github.com/eventlet/eventlet/issues/151
- nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}