summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-16 02:32:03 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-17 09:48:08 +0200
commit1493ca72a06bef5e5884df268657409d4b204003 (patch)
treeb4e7e85e429bea4477b032890936dd448c7d0967 /dev-python/exam
parentnet-analyzer/pnp4nagios: fix metadata for icinga removal (diff)
downloadgentoo-1493ca72a06bef5e5884df268657409d4b204003.tar.gz
gentoo-1493ca72a06bef5e5884df268657409d4b204003.tar.bz2
gentoo-1493ca72a06bef5e5884df268657409d4b204003.zip
dev-python/exam: new package
Exam is a Python toolkit for writing better tests. Closes: https://bugs.gentoo.org/710912 Package-Manager: Portage-2.3.94, Repoman-2.3.20 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14964 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/exam')
-rw-r--r--dev-python/exam/Manifest1
-rw-r--r--dev-python/exam/exam-0.10.6.ebuild22
-rw-r--r--dev-python/exam/metadata.xml28
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/exam/Manifest b/dev-python/exam/Manifest
new file mode 100644
index 000000000000..4234b47f2bb9
--- /dev/null
+++ b/dev-python/exam/Manifest
@@ -0,0 +1 @@
+DIST exam-0.10.6.tar.gz 15028 BLAKE2B 6d2a888b9adf14665e8f009bae7b2c724dcb60fe19efa98a189988a73a0cb5933179407c754ed1c19b24694080b6df31838768f694460fabd9196e58e8b4c94d SHA512 1cc082b4fb9a7270ea81750ee3f34400f3f6eac65dd1488af333a43d0623bf8f9176b73e2948c324bb9c0062296284bae66fe215263456baf9db378676c8a4f0
diff --git a/dev-python/exam/exam-0.10.6.ebuild b/dev-python/exam/exam-0.10.6.ebuild
new file mode 100644
index 000000000000..3936796fb019
--- /dev/null
+++ b/dev-python/exam/exam-0.10.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers for better testing"
+HOMEPAGE="https://github.com/fluxx/exam"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
diff --git a/dev-python/exam/metadata.xml b/dev-python/exam/metadata.xml
new file mode 100644
index 000000000000..e782094b1d21
--- /dev/null
+++ b/dev-python/exam/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fluxx/exam</remote-id>
+ </upstream>
+ <longdescription lang="en">
+Exam is a Python toolkit for writing better tests. It aims to remove a lot of the boiler plate testing code one often writes, while still following Python conventions and adhering to the unit testing interface.
+
+Aside from the obvious "does the code work?", writings tests has many additional goals and benefits:
+
+ If written semantically, reading tests can help demonstrate how the code is supposed to work to other developers.
+ If quick running, tests provide feedback during development that your changes are working or not having an adverse side effects.
+ If they're easy to write correctly, developers will write more tests and they will be of a higher quality.
+
+Unfortunately, the common pattern for writing Python unit tests tends to not offer any of these advantages. Often times results in inefficient and unnecessarily obtuse testing code. Additionally, common uses of the mock library can often result in repetitive boiler-plate code or inefficiency during test runs.
+
+exam aims to improve the state of Python test writing by providing a toolkit of useful functionality to make writing quick, correct and useful tests and as painless as possible.
+ </longdescription>
+</pkgmetadata>