summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-30 14:16:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-30 14:22:03 +0100
commit261edc836ab68bb8b3cf6208f66ad0a00be4a40c (patch)
tree269828d97e6abd7e935c6861e04d54f8d1f68995 /dev-python/executing/executing-1.1.1.ebuild
parentdev-python/asttokens: Remove old (diff)
downloadgentoo-261edc836ab68bb8b3cf6208f66ad0a00be4a40c.tar.gz
gentoo-261edc836ab68bb8b3cf6208f66ad0a00be4a40c.tar.bz2
gentoo-261edc836ab68bb8b3cf6208f66ad0a00be4a40c.zip
dev-python/executing: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing/executing-1.1.1.ebuild')
-rw-r--r--dev-python/executing/executing-1.1.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/executing/executing-1.1.1.ebuild b/dev-python/executing/executing-1.1.1.ebuild
deleted file mode 100644
index c30d19f28ed4..000000000000
--- a/dev-python/executing/executing-1.1.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/
-"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/littleutils[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}
-
-pkg_postinst() {
- optfeature "getting node's source code" dev-python/asttokens
-}