summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-17 22:15:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-17 22:24:25 +0300
commit7e902a9a40fb2395c9cec252f6d09e113b75ab96 (patch)
treefdb8f072db50951b9e88c0b541f08ff26c2478b6 /dev-python/executing
parentdev-python/python-levenshtein: drop 0.12.1 (diff)
downloadgentoo-7e902a9a40fb2395c9cec252f6d09e113b75ab96.tar.gz
gentoo-7e902a9a40fb2395c9cec252f6d09e113b75ab96.tar.bz2
gentoo-7e902a9a40fb2395c9cec252f6d09e113b75ab96.zip
dev-python/executing: drop 0.7.0, 0.8.0, 0.8.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest3
-rw-r--r--dev-python/executing/executing-0.7.0.ebuild37
-rw-r--r--dev-python/executing/executing-0.8.0.ebuild37
-rw-r--r--dev-python/executing/executing-0.8.1.ebuild37
4 files changed, 0 insertions, 114 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 86ed6d76235a..a39b3b6667a3 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,4 +1 @@
-DIST executing-0.7.0.gh.tar.gz 452550 BLAKE2B 9b3bdb49b3b00ca17952db747d3f0f3995e8dffbc170bcb2260e7c34ce9e6b0c8e1620be2e2776445a6114add4e2437eaeae8a308391e2c121b6484b5bc6056c SHA512 08ee347f0bcaf04ca2c6010762a6d2d5b054b3590029c55d18d6efae5a5db7c6c5a0948cce9d9684e4bfbfd9ea19326e4ac2c96be40535c0500c28c28ce81e07
-DIST executing-0.8.0.gh.tar.gz 494306 BLAKE2B 37ce7c743380dcac85e6843e8ee708c8d876c5de883e49786da67d94dc9a7bf983bb36278a823ddb2bc9291e7219125cf870fac8c0c28979a4b49e951410d5e5 SHA512 6f88052f61479c5fe4aba1925e90f3daea3852f636c5c17d94a08dfa4de909fb3187650ff07c1dc66b4b3bec4a04cfdaf4cfe0c37903f67b2d716691d07a93d8
-DIST executing-0.8.1.gh.tar.gz 494735 BLAKE2B db57f01a6501b2c709140d806119a455db2294f410bb1602bbe96d3b45c4301b9517654fcdc00c31b6dcd3365476d29a944e38d340f82338ed1059f0a878753e SHA512 592035eeef74dc83fd72a08910e3cbacebe70f8206c55ba54661d8a11b7aee105de59487a957caf71799b0f3f5239e601a4de5d19553f33d21983c23a199c383
DIST executing-0.8.2.gh.tar.gz 494836 BLAKE2B d6ade5658c8df656e80bb596f6c19493475d74ea10ddfc60b25eadb4a2f68d8afd2f437a6f82807932bba0469617fdac7a4dd90569623d1c8d7f96220e02ec9a SHA512 9a7fe4d3bae77d49725f35bae9d239bfb2a6e89d893d871d76f26fe4beffe0a07c6cbf50ea7b35b9ced66148d015c48106bc5774b26f201f9b40577f3380f5b3
diff --git a/dev-python/executing/executing-0.7.0.ebuild b/dev-python/executing/executing-0.7.0.ebuild
deleted file mode 100644
index 42bd4eaab9d9..000000000000
--- a/dev-python/executing/executing-0.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-# asttokens is optional runtime dep
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}
diff --git a/dev-python/executing/executing-0.8.0.ebuild b/dev-python/executing/executing-0.8.0.ebuild
deleted file mode 100644
index a5e893cb9f44..000000000000
--- a/dev-python/executing/executing-0.8.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-# asttokens is optional runtime dep
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}
diff --git a/dev-python/executing/executing-0.8.1.ebuild b/dev-python/executing/executing-0.8.1.ebuild
deleted file mode 100644
index e01cf6c3100d..000000000000
--- a/dev-python/executing/executing-0.8.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-# asttokens is optional runtime dep
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}