summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-24 15:38:19 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-24 15:42:24 -0500
commitf4d0cf625270fee176371f647bb8282353d5378e (patch)
treeb73d997f9b9a1b68aead7a4f80c38005d2b1d65b /dev-python/expects/expects-0.8.0_rc2.ebuild
parentdev-python/expects: add version 0.8.0_rc4 (diff)
downloadgentoo-f4d0cf625270fee176371f647bb8282353d5378e.tar.gz
gentoo-f4d0cf625270fee176371f647bb8282353d5378e.tar.bz2
gentoo-f4d0cf625270fee176371f647bb8282353d5378e.zip
dev-python/expects: remove version 0.8.0_rc2
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/expects/expects-0.8.0_rc2.ebuild')
-rw-r--r--dev-python/expects/expects-0.8.0_rc2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/expects/expects-0.8.0_rc2.ebuild b/dev-python/expects/expects-0.8.0_rc2.ebuild
deleted file mode 100644
index f96e4611ab67..000000000000
--- a/dev-python/expects/expects-0.8.0_rc2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PV=${PV/_/}
-
-DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
-HOMEPAGE="https://github.com/jaimegildesagredo/expects"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/mamba[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- mamba || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}