summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-02 15:20:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-02 15:20:13 +0300
commit28c3726f57a31b2df2476493aec799775c8cae94 (patch)
treecf5c4dc288ba54f249f9490522c41a56e0778174 /dev-python/eyeD3
parentdev-python/eyeD3: Stabilize 0.9.6-r1 ALLARCHES, #855833 (diff)
downloadgentoo-28c3726f57a31b2df2476493aec799775c8cae94.tar.gz
gentoo-28c3726f57a31b2df2476493aec799775c8cae94.tar.bz2
gentoo-28c3726f57a31b2df2476493aec799775c8cae94.zip
dev-python/eyeD3: drop 0.9.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/eyeD3')
-rw-r--r--dev-python/eyeD3/eyeD3-0.9.6.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/eyeD3/eyeD3-0.9.6.ebuild b/dev-python/eyeD3/eyeD3-0.9.6.ebuild
deleted file mode 100644
index 8245a9dc9755..000000000000
--- a/dev-python/eyeD3/eyeD3-0.9.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
-HOMEPAGE="https://eyed3.nicfit.net/"
-SRC_URI="https://github.com/nicfit/eyeD3/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://eyed3.nicfit.net/releases/eyeD3-test-data.tgz )"
-
-LICENSE="GPL-2"
-SLOT="0.7"
-KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/deprecation[${PYTHON_USEDEP}]
- dev-python/filetype[${PYTHON_USEDEP}]"
-# note: most of the deps are optional runtime deps / plugin deps
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pylast[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # requires unpackaged factory-boy, doesn't seem to relevant
- # to anything but eyeD3 usage with factory-boy
- rm tests/test_factory.py || die
- # requires unpackaged grako
- rm tests/test_display_plugin.py || die
-
- if use test; then
- mv "${WORKDIR}"/eyeD3-test-data tests/data || die
- fi
-
- distutils-r1_src_prepare
-}