summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-12-05 15:07:29 -0600
committerBen Kohler <bkohler@gentoo.org>2019-12-05 15:07:46 -0600
commitee23cf9880da8dabc903357266834019797d3429 (patch)
tree45d0c6471dd7eeb7687999dde18091d53b01bd4e /dev-python/eyeD3
parentdev-python/paver: add missing six dep, and add python3_7 (diff)
downloadgentoo-ee23cf9880da8dabc903357266834019797d3429.tar.gz
gentoo-ee23cf9880da8dabc903357266834019797d3429.tar.bz2
gentoo-ee23cf9880da8dabc903357266834019797d3429.zip
dev-python/eyeD3: bump to 0.8.11 with python3 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'dev-python/eyeD3')
-rw-r--r--dev-python/eyeD3/Manifest1
-rw-r--r--dev-python/eyeD3/eyeD3-0.8.11.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/eyeD3/Manifest b/dev-python/eyeD3/Manifest
index 719930771746..8e2d826b8554 100644
--- a/dev-python/eyeD3/Manifest
+++ b/dev-python/eyeD3/Manifest
@@ -1 +1,2 @@
DIST eyeD3-0.7.5.tgz 221685 BLAKE2B c296f61036cd0e43f1820c830e9fa9630d8bb56770c36c922ec0bbbd2ed9566c4a0330677dc1c7fd6cc6fa30f9b415abef2867d93a55ba337b520ed52e330c39 SHA512 9f57e05e4db78618e73ec15ca6ac7b983e13c24ae926bfb9194ee4fc1d735f80308dfc5bdac6016f5491bdb06d46b645d7ac54247d581467a8a22129fae85ba5
+DIST v0.8.11.tar.gz 215807 BLAKE2B e289a274198a4adceb0ec3b77a5c79f50faaa320edecdf07d1d2af3b5519f0c884c8cef146b124fd172d74626f70af2b689dd536ade1a68ed27fedff840513ee SHA512 ed147fbe6ce88319cdbfc752e1ddbcb141180bdd87854c209c621956bc52395c5ba442d929016419620c0b230f5b8a3e1fa638b73c7cf329405425148f953c9c
diff --git a/dev-python/eyeD3/eyeD3-0.8.11.ebuild b/dev-python/eyeD3/eyeD3-0.8.11.ebuild
new file mode 100644
index 000000000000..f0827dd3aaa2
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.8.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="http://eyed3.nicfit.net/"
+SRC_URI="https://github.com/nicfit/eyeD3/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/paver[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]"