summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 11:12:58 +0100
committerSam James <sam@gentoo.org>2022-05-31 11:14:10 +0100
commitf27b938cac7e3d14d802072a646b90c7453a2cb4 (patch)
tree3129b02e03fee95d62fad92e190a526b84052561 /dev-python/eyeD3
parentdev-python/deprecation: enable py3.11 (diff)
downloadgentoo-f27b938cac7e3d14d802072a646b90c7453a2cb4.tar.gz
gentoo-f27b938cac7e3d14d802072a646b90c7453a2cb4.tar.bz2
gentoo-f27b938cac7e3d14d802072a646b90c7453a2cb4.zip
dev-python/eyeD3: add Python 3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/eyeD3')
-rw-r--r--dev-python/eyeD3/eyeD3-0.9.6-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/eyeD3/eyeD3-0.9.6-r1.ebuild b/dev-python/eyeD3/eyeD3-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..a29cbbbf2096
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.9.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="https://eyed3.nicfit.net/"
+SRC_URI="https://github.com/nicfit/eyeD3/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://eyed3.nicfit.net/releases/eyeD3-test-data.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/filetype[${PYTHON_USEDEP}]
+ || (
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+# note: most of the deps are optional runtime deps / plugin deps
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # requires unpackaged factory-boy, doesn't seem to relevant
+ # to anything but eyeD3 usage with factory-boy
+ rm tests/test_factory.py || die
+ # requires unpackaged grako
+ rm tests/test_display_plugin.py || die
+
+ if use test; then
+ mv "${WORKDIR}"/eyeD3-test-data tests/data || die
+ fi
+
+ distutils-r1_src_prepare
+}