summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 10:07:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 10:07:27 +0200
commit684c01aba2bc929549917484df9db43e3453ad18 (patch)
treea68e2f6f086226e79a7749934bcea11fb67830b8 /dev-python/fakeredis
parentdev-python/asttokens: Remove old (diff)
downloadgentoo-684c01aba2bc929549917484df9db43e3453ad18.tar.gz
gentoo-684c01aba2bc929549917484df9db43e3453ad18.tar.bz2
gentoo-684c01aba2bc929549917484df9db43e3453ad18.zip
dev-python/fakeredis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-1.8.2.ebuild88
-rw-r--r--dev-python/fakeredis/fakeredis-1.9.0.ebuild88
3 files changed, 0 insertions, 178 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index fd3828aebd3e..cefe2b01cc4d 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1 @@
-DIST fakeredis-py-1.8.2.gh.tar.gz 96238 BLAKE2B 17fd75d2ca6e929fbbdab87e9a6450d72006a3dc72a2d81a3f381c1918f2ca12f273468bf8015e80df78e9df393d2f7002b13e12989d108f93beb3287472c0c6 SHA512 6a86c0fa41920f4446b66d4d152850227a23f5a031a80d0d9109117de7252965821dc8d9f022b9fd703f8ed66fad207f6542bd6ee524a54f2053bbcd2ed9965e
-DIST fakeredis-py-1.9.0.gh.tar.gz 85475 BLAKE2B 99c5fdf2fb665505f6450a3ec08a401a0a629c62722709b4775ac2752816e6b461579f4a3df6d7a11a07e170e369ee1703294d9ef607a52318a7a8d583ce6264 SHA512 ca379d610a62053bb417aad1cd618356240697d0afdaca0467506d7b1ec38997d46b358a31356cdec8ecd1719386f942fd220f8b0a396bfc8c5316c2143f20f1
DIST fakeredis-py-1.9.1.gh.tar.gz 86742 BLAKE2B aa3f0b05f486219cb6eb560f561ab3e39cc32286cdc3f4f9aba667e256528b9338dcc03f3ddb00c0db30ddb181afe535e209f6ee0e98c56a0cad445e2181ec67 SHA512 27b4c95e596fdd69cecc737897edfedd6f55e7c5610394b1532e4b2aededaed6ad15763582ce6cc20821ac7ea096f60204f7080d247359d8e8d0d360a61c8e39
diff --git a/dev-python/fakeredis/fakeredis-1.8.2.ebuild b/dev-python/fakeredis/fakeredis-1.8.2.ebuild
deleted file mode 100644
index e9f273d84f0c..000000000000
--- a/dev-python/fakeredis/fakeredis-1.8.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=fakeredis-py-${PV}
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/cunla/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-SRC_URI="
- https://github.com/cunla/fakeredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin redis
- sed -i -e '/redis/s:<[0-9.]*:*:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/fakeredis/fakeredis-1.9.0.ebuild b/dev-python/fakeredis/fakeredis-1.9.0.ebuild
deleted file mode 100644
index 0b30f3d6134d..000000000000
--- a/dev-python/fakeredis/fakeredis-1.9.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=fakeredis-py-${PV}
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/cunla/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-SRC_URI="
- https://github.com/cunla/fakeredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- <dev-python/redis-py-4.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin redis
- sed -i -e '/redis/s:<[0-9.]*:*:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}