summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-20 04:14:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-20 04:50:10 +0200
commit6daee68519b97e55ce7c7f5ff2d1c418f3e5ca66 (patch)
tree4bce2f12e3e35adf48fbaa4d33ced68bf07ee754 /dev-python/fakeredis
parentsys-auth/pambase: add 20201020 (diff)
downloadgentoo-6daee68519b97e55ce7c7f5ff2d1c418f3e5ca66.tar.gz
gentoo-6daee68519b97e55ce7c7f5ff2d1c418f3e5ca66.tar.bz2
gentoo-6daee68519b97e55ce7c7f5ff2d1c418f3e5ca66.zip
dev-python/fakeredis: Bump to 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.4.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 716be373f2bf..cd00262d0511 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1 +1,2 @@
DIST fakeredis-1.4.3.gh.tar.gz 64936 BLAKE2B 61f85ec5c5b05b45f421a422f0cab072c24864a970097d2e15340ba7655ba9182c312091b9b6570aaf366fc241bb430fa528068db2728d42b615aecbec635d1a SHA512 56a0cc6d51025ceb24bb46dcdb2a8f638699f9928552d9b0f1592ff93903397304a9166e167de4d7c1d9f718a486f71e249c36e7c0667bde59f46710896da987
+DIST fakeredis-1.4.4.gh.tar.gz 65483 BLAKE2B 500346bb96d2c1308d0565a006ca037784ff25670fd313c94df13f0ceb6d90dbec044c71c95bdabbd593823e26b47a8f8f2a2f7f5b3fa9307b9ccea407b2872c SHA512 04b85675b088e698f11edf8727b88544640cac0caa0048f009371a4c9a9ebc17443d8f03c9ead20ca40608f618c4d394cd6ba4c9d1e5e59b058713756856e450
diff --git a/dev-python/fakeredis/fakeredis-1.4.4.ebuild b/dev-python/fakeredis/fakeredis-1.4.4.ebuild
new file mode 100644
index 000000000000..0ca618c58661
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # tests for use with aioredis, not packaged in ::gentoo
+ --ignore test/test_aioredis.py
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+
+ pytest -vv "${excludes[@]}" || die "Tests failed with ${EPYTHON}"
+}