summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-10 21:07:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-10 21:09:22 +0200
commitbb3e1c672d8b77eee7ff0ea20a2c4561a8e62694 (patch)
tree3b2ce3232d8ceaa2e1215c6e97a6c7de33317a2e /dev-python/fakeredis
parentdev-python/jupyter_server: Remove old (diff)
downloadgentoo-bb3e1c672d8b77eee7ff0ea20a2c4561a8e62694.tar.gz
gentoo-bb3e1c672d8b77eee7ff0ea20a2c4561a8e62694.tar.bz2
gentoo-bb3e1c672d8b77eee7ff0ea20a2c4561a8e62694.zip
dev-python/fakeredis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-1.7.1.ebuild81
-rw-r--r--dev-python/fakeredis/fakeredis-1.8.ebuild92
3 files changed, 0 insertions, 175 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index b0454a6f70c6..33738459bc11 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1 @@
-DIST fakeredis-1.7.1.gh.tar.gz 71151 BLAKE2B 87877c94a4c03ad6ff4b55f307526f712daa860257374a97a8f7bd29440d171467e18e4041ca56bb6af30df30481a3d5b13c7d0657ba3eb7673a653664ffbe8a SHA512 f41d9393ae50bae9de064678948f4364fc47db06f489782e5b428f449828ad5813b08b2fb053bef878b2a1b500edbb0ea1881449dbd12c2b6e385f6a2fba4c59
DIST fakeredis-py-1.8.1.gh.tar.gz 101586 BLAKE2B a1b123dd482b9b59f401a855ba95a08f2e744bff5ae4a4f0c12cde8b2a05971043ccb16e92d0adbfeedd3e071fab50f1328ed265c6ac19ecf6932d09bcacd549 SHA512 19e1636895206fa550844a776ba4835c3acbe2eac8fb774716e91d20e0f283b121f42ee11d876e20d798a6df0dcfcc29114c76c839c4946436102b8f83ed3d01
-DIST fakeredis-py-1.8.gh.tar.gz 101156 BLAKE2B e799b5636a89edd8795fdc79811689cd308f8a7dae55d7ac4045352f370f428d96fdfed7886598e856c203bcc44d58236a8bf5229ee49a9cec90324f0778ce78 SHA512 7bd553dc724b9d664ff1c403fd9a234ad7a8e95f81a3761eef28c7e6d919b7756040a70382e61d9ff54f8bd8f778130c035e9384707403ca9a4340051a4cf861
diff --git a/dev-python/fakeredis/fakeredis-1.7.1.ebuild b/dev-python/fakeredis/fakeredis-1.7.1.ebuild
deleted file mode 100644
index 26b7c45d2eee..000000000000
--- a/dev-python/fakeredis/fakeredis-1.7.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- <dev-python/redis-py-4.2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/aioredis[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- test/test_aioredis2.py::test_blocking_unblock
- test/test_aioredis2.py::test_pubsub
- "test/test_aioredis2.py::test_repr[fake]"
- test/test_hypothesis.py::TestJoint::test
- test/test_hypothesis.py::TestFuzz::test
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- "test/test_aioredis2.py::test_failed_script_error[fake]"
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-pkg_postinst() {
- optfeature "Mock aioredis" dev-python/aioredis
-}
diff --git a/dev-python/fakeredis/fakeredis-1.8.ebuild b/dev-python/fakeredis/fakeredis-1.8.ebuild
deleted file mode 100644
index c1adeb1fb405..000000000000
--- a/dev-python/fakeredis/fakeredis-1.8.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1 optfeature
-
-MY_P=fakeredis-py-${PV}
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/dsoftwareinc/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-SRC_URI="
- https://github.com/dsoftwareinc/fakeredis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/redis-py-4.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin redis
- sed -i -e '/redis/s:<=[0-9.]*:*:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-pkg_postinst() {
- optfeature "Mock aioredis" dev-python/aioredis
-}