summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 17:13:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 17:19:42 +0200
commit9c1e7d39b2bb42b4819a4d1c028a58c63a863ee1 (patch)
tree642daa26257bc2203129f241b6d6b8325e3de70d /dev-python/fastimport
parentdev-python/django-tables2: Bump to 2.4.1 (diff)
downloadgentoo-9c1e7d39b2bb42b4819a4d1c028a58c63a863ee1.tar.gz
gentoo-9c1e7d39b2bb42b4819a4d1c028a58c63a863ee1.tar.bz2
gentoo-9c1e7d39b2bb42b4819a4d1c028a58c63a863ee1.zip
dev-python/fastimport: Bump to 0.9.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastimport')
-rw-r--r--dev-python/fastimport/Manifest1
-rw-r--r--dev-python/fastimport/fastimport-0.9.14.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastimport/Manifest b/dev-python/fastimport/Manifest
index dc0fac2f32f5..b9f9fe69e57a 100644
--- a/dev-python/fastimport/Manifest
+++ b/dev-python/fastimport/Manifest
@@ -1 +1,2 @@
DIST fastimport-0.9.11.tar.gz 41764 BLAKE2B afb82878ea1996894ff71fe99edc5ca26d45f98eedf7a8a6e85af45949e1e81c2112de9fc2c026438306a8a0e89c484063954ba7d2ff9a80c6b71ab40174f8d4 SHA512 e1b7e4897542ef6f33af51e1018340a6807688e44424e4e7e482b3347264d58d4290678cc2cfa230af500a53cabdcf35c9e7b03c8ff0f1ec3e6e0a9e869a1455
+DIST fastimport-0.9.14.tar.gz 41791 BLAKE2B b0becb3de319c44e60cf8575afd9b19ad69ca8715d9eae8ced079136dccadda82ac340ad7e01f8a556bde07fbecfbbe6f9eb841909ee2e6b6bbe8e808f463e43 SHA512 cbf8f0bf5b66e847d4482b6af29ee26a69a2aadefe22c4a2f17d976a94fce86b016b61b17d0a7f4be82ceb7824d0bc12b509b8148c18f9dc8888304158a7c266
diff --git a/dev-python/fastimport/fastimport-0.9.14.ebuild b/dev-python/fastimport/fastimport-0.9.14.ebuild
new file mode 100644
index 000000000000..3c97842c7061
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="
+ https://github.com/jelmer/python-fastimport/
+ https://pypi.org/project/fastimport/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}