summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-15 06:40:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-15 06:55:09 +0100
commit35d3e18e5295d9482efa8a8750829d343daa1397 (patch)
treebb2ccdc85b09ef4d56c9643715fee458f04c3e49 /dev-python/fastjsonschema
parentdev-python/jsonschema-specifications: Bump to 2023.11.1 (diff)
downloadgentoo-35d3e18e5295d9482efa8a8750829d343daa1397.tar.gz
gentoo-35d3e18e5295d9482efa8a8750829d343daa1397.tar.bz2
gentoo-35d3e18e5295d9482efa8a8750829d343daa1397.zip
dev-python/fastjsonschema: Bump to 2.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.19.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 4bf7308e00ef..9c9755081444 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST fastjsonschema-2.18.1.tar.gz 371060 BLAKE2B fc77683215e9080d3a6f162336a7ed55550a310c9921f0e669d90bfaea659dd77ad27ed0c623b0355d5efafa3ca2e83f72edf228c42cca0fc4fa16f4f474aa6b SHA512 a08fce64a67c67a06a7c3c637047648e1b2cfa749291794b8accc6dcc1ccf744eb50c8db773734017b79612b2dc4e19730a5956807b2459928fb0b996b59711e
+DIST fastjsonschema-2.19.0.tar.gz 371202 BLAKE2B 56103ae94d52a337ceb830b7dfe68b3e1c3d5bdfbe46c8c042b5bc1a6d4e36201176a274135779cbf50a9ce939d95f5bd3c5bd88b7a6483db4cc438bff1d986a SHA512 d26c7f44acfeb4210fad188e3fe5486231a516fb0a4fa7d756dd9d1378b22afd7b4acb6b34085cabcfe31dac44a605de6f90a158a3af69de97f8926d59b3a105
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.19.0.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.19.0.ebuild
new file mode 100644
index 000000000000..e1529c815ca6
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.19.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)