summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-19 20:48:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-19 21:28:07 +0300
commit7ff46cb73373a885de963fd87b28e08296522616 (patch)
tree39cc162b16aab9ccb5b618c0c3c13d1cd48e9066 /dev-python/fastjsonschema
parentdev-python/python-email-validator: add 1.3.0 (diff)
downloadgentoo-7ff46cb73373a885de963fd87b28e08296522616.tar.gz
gentoo-7ff46cb73373a885de963fd87b28e08296522616.tar.bz2
gentoo-7ff46cb73373a885de963fd87b28e08296522616.zip
dev-python/fastjsonschema: add 2.16.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.16.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 52fd8651ee26..6f2d2916bc13 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST python-fastjsonschema-2.16.1.gh.tar.gz 391733 BLAKE2B 7d53b51ad88fb6e11226510f3dc7f7ef8ca2d6e22825e31f32fe7b9343c2d7bf946c0d528ecdb9550abd5e5dd01f2bf52d6670fa644eb4b453f2a45080cd9318 SHA512 b3ef41926ec6a54d527f68f6c198fdc61fc6528449137557a3f2130c5d01914a6ea3300bc6efb90f9b8fefbb98464760378108ef221dcb021414b2e0ffb1eb73
+DIST python-fastjsonschema-2.16.2.gh.tar.gz 391619 BLAKE2B ea8da31d16ec7c9a897de0b2a91832ce26798d2dc048e70e862ce7a4e75787cd25ee4b9e14fac9f85599e050338b6306a2549a0a8bab9abcbfbd12c246d10697 SHA512 17fce033e6d334e82813af7366006ade29433efe291a1567ae494c2273b9ab87b8fa4ccf1bae0b7062f9f70fe492449c87a5d07075d79037ac2c755ed9278a23
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.16.2.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.16.2.ebuild
new file mode 100644
index 000000000000..4d2f3bd44cd4
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.16.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}