summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-01 20:59:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-01 21:02:01 +0300
commit90ff08f710e6048513297f72edd826c3c06d015d (patch)
tree6d0bb05688d04dd1ecfa023c76fab78d4d5f7817 /dev-python/fastjsonschema
parentdev-python/xlsxwriter: add 3.1.6 (diff)
downloadgentoo-90ff08f710e6048513297f72edd826c3c06d015d.tar.gz
gentoo-90ff08f710e6048513297f72edd826c3c06d015d.tar.bz2
gentoo-90ff08f710e6048513297f72edd826c3c06d015d.zip
dev-python/fastjsonschema: add 2.18.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.18.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 47a5ec364df9..0d09a3fa0c8a 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST fastjsonschema-2.18.0.tar.gz 371063 BLAKE2B d2b79eb442351487ffebc59ff48af1e8f07fb5e2ca97059cc98cc8f02eda3523fcf60b2aa6b46edc1d3d019ed04d65d2fc5c3eee58471ea9b2a0bd0bf7bf40ed SHA512 848ea4587edb9d694d4f42cee35c8a6a785f601b3e84daae5a5b155ca61c0c7de1b9164e86c0a48166d429a4a737799480dfdeaad7e81eab28f68f71dd46988f
+DIST fastjsonschema-2.18.1.tar.gz 371060 BLAKE2B fc77683215e9080d3a6f162336a7ed55550a310c9921f0e669d90bfaea659dd77ad27ed0c623b0355d5efafa3ca2e83f72edf228c42cca0fc4fa16f4f474aa6b SHA512 a08fce64a67c67a06a7c3c637047648e1b2cfa749291794b8accc6dcc1ccf744eb50c8db773734017b79612b2dc4e19730a5956807b2459928fb0b996b59711e
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.18.1.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.18.1.ebuild
new file mode 100644
index 000000000000..ec0f5cdb075d
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.18.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)