summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-09-05 18:32:12 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-09-05 20:41:10 -0500
commit4e1aad3874d76a06b4624274c361bc8580bff702 (patch)
treee5bd2a8c5936ec18eb7fa3ca31ca988324d2f226 /dev-python/faulthandler/faulthandler-2.6.ebuild
parentmedia-sound/pianobar: version bump to 2017.08.30 (diff)
downloadgentoo-4e1aad3874d76a06b4624274c361bc8580bff702.tar.gz
gentoo-4e1aad3874d76a06b4624274c361bc8580bff702.tar.bz2
gentoo-4e1aad3874d76a06b4624274c361bc8580bff702.zip
dev-python/faulthandler: initial commit
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/faulthandler/faulthandler-2.6.ebuild')
-rw-r--r--dev-python/faulthandler/faulthandler-2.6.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/faulthandler/faulthandler-2.6.ebuild b/dev-python/faulthandler/faulthandler-2.6.ebuild
new file mode 100644
index 000000000000..98e5c2804c53
--- /dev/null
+++ b/dev-python/faulthandler/faulthandler-2.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="functions to dump Python tracebacks explicitly (on fault, user signal, timeout)"
+HOMEPAGE="https://github.com/haypo/faulthandler https://pypi.python.org/pypi/faulthandler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""