summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-09-15 20:26:47 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-09-16 06:34:17 +0200
commit5a840ef9cea7996f9feb3360d8303b6f4dd1f54f (patch)
tree58532806df3f5816161ea66cf7041a76106100e4 /dev-python/fcl
parentdev-python/vecrec: new package (diff)
downloadgentoo-5a840ef9cea7996f9feb3360d8303b6f4dd1f54f.tar.gz
gentoo-5a840ef9cea7996f9feb3360d8303b6f4dd1f54f.tar.bz2
gentoo-5a840ef9cea7996f9feb3360d8303b6f4dd1f54f.zip
dev-python/fcl: new package
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17558 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/fcl')
-rw-r--r--dev-python/fcl/Manifest1
-rw-r--r--dev-python/fcl/fcl-0.0.12.ebuild43
-rw-r--r--dev-python/fcl/metadata.xml16
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/fcl/Manifest b/dev-python/fcl/Manifest
new file mode 100644
index 000000000000..c8d389d0a36c
--- /dev/null
+++ b/dev-python/fcl/Manifest
@@ -0,0 +1 @@
+DIST python-fcl-0.0.12.tar.gz 17204 BLAKE2B 594d466270160e71e67d99f1745b382c3b1f7754adeb9ba58443e4370e14496e45f4a7619eb7d41db22766f75fe841e088609014bf5a9ff5a6b7ee526b34eca2 SHA512 3b5462206e63e17c646edeeedb268474cc6df1ff12d64d4de0c46bcc281787a42b6306778d2fe5d4d3b2e23bc0ed86e092c9a39b74d019638c771ac5c9d9f8ce
diff --git a/dev-python/fcl/fcl-0.0.12.ebuild b/dev-python/fcl/fcl-0.0.12.ebuild
new file mode 100644
index 000000000000..56e45b519abe
--- /dev/null
+++ b/dev-python/fcl/fcl-0.0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..7} )
+
+inherit distutils-r1
+
+MY_PN="python-fcl"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for the Flexible Collision Library"
+HOMEPAGE="https://github.com/BerkeleyAutomation/python-fcl https://pypi.org/project/python-fcl/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ~sci-libs/fcl-0.5.0
+ sci-libs/octomap
+"
+
+S=${WORKDIR}/${MY_P}
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r example
+ fi
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ "${EPYTHON}" test/test_fcl.py -v || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/fcl/metadata.xml b/dev-python/fcl/metadata.xml
new file mode 100644
index 000000000000..4dae84fa0a47
--- /dev/null
+++ b/dev-python/fcl/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Python-FCL is an (unofficial) Python interface for the Flexible Collision Library (FCL), an excellent C++
+ library for performing proximity and collision queries on pairs of geometric models.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">BerkeleyAutomation/python-fcl</remote-id>
+ <remote-id type="pypi">python-fcl</remote-id>
+ </upstream>
+</pkgmetadata>