summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 18:58:54 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 19:43:16 +0200
commit8cf290c49e9435122e2d55666d5b9aba00c95f18 (patch)
tree577e43bf2a352ed8a8cbf53ba0e77463fd1c59dc /dev-python/feedparser/files
parentdev-python/freezegun: Clean old versions up (diff)
downloadgentoo-8cf290c49e9435122e2d55666d5b9aba00c95f18.tar.gz
gentoo-8cf290c49e9435122e2d55666d5b9aba00c95f18.tar.bz2
gentoo-8cf290c49e9435122e2d55666d5b9aba00c95f18.zip
dev-python/feedparser: Clean old versions up
Diffstat (limited to 'dev-python/feedparser/files')
-rw-r--r--dev-python/feedparser/files/feedparser-5.1-sgmllib.patch78
-rw-r--r--dev-python/feedparser/files/feedparser-5.1.3-backport_fix_for_chardet-py3.patch32
2 files changed, 0 insertions, 110 deletions
diff --git a/dev-python/feedparser/files/feedparser-5.1-sgmllib.patch b/dev-python/feedparser/files/feedparser-5.1-sgmllib.patch
deleted file mode 100644
index 63c12ba0c362..000000000000
--- a/dev-python/feedparser/files/feedparser-5.1-sgmllib.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 812793c07d3202d3f5bc39091aec2e7071d000c8 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sun, 1 Jan 2012 19:30:57 +0100
-Subject: [PATCH] Use shipped sgmllib for Python 3.x
-
----
- feedparser/feedparser.py | 19 +++----------------
- setup.py | 2 +-
- 2 files changed, 4 insertions(+), 17 deletions(-)
-
-diff --git a/feedparser/feedparser.py b/feedparser/feedparser.py
-index 8275c29..9a8a053 100644
---- a/feedparser/feedparser.py
-+++ b/feedparser/feedparser.py
-@@ -204,17 +204,9 @@ else:
- try:
- import sgmllib
- except ImportError:
-- # This is probably Python 3, which doesn't include sgmllib anymore
-- _SGML_AVAILABLE = 0
-+ import _feedparser_sgmllib as sgmllib
-
-- # Mock sgmllib enough to allow subclassing later on
-- class sgmllib(object):
-- class SGMLParser(object):
-- def goahead(self, i):
-- pass
-- def parse_starttag(self, i):
-- pass
--else:
-+if True:
- _SGML_AVAILABLE = 1
-
- # sgmllib defines a number of module-level regular expressions that are
-@@ -2520,9 +2512,6 @@ class _RelativeURIResolver(_BaseHTMLProcessor):
- _BaseHTMLProcessor.unknown_starttag(self, tag, attrs)
-
- def _resolveRelativeURIs(htmlSource, baseURI, encoding, _type):
-- if not _SGML_AVAILABLE:
-- return htmlSource
--
- p = _RelativeURIResolver(baseURI, encoding, _type)
- p.feed(htmlSource)
- return p.output()
-@@ -2803,8 +2792,6 @@ class _HTMLSanitizer(_BaseHTMLProcessor):
-
-
- def _sanitizeHTML(htmlSource, encoding, _type):
-- if not _SGML_AVAILABLE:
-- return htmlSource
- p = _HTMLSanitizer(encoding, _type)
- htmlSource = htmlSource.replace('<![CDATA[', '&lt;![CDATA[')
- p.feed(htmlSource)
-@@ -3890,7 +3877,7 @@ def parse(url_file_stream_or_string, etag=None, modified=None, agent=None, refer
- result['bozo'] = 1
- result['bozo_exception'] = feedparser.exc or e
- use_strict_parser = 0
-- if not use_strict_parser and _SGML_AVAILABLE:
-+ if not use_strict_parser:
- feedparser = _LooseFeedParser(baseuri, baselang, 'utf-8', entities)
- feedparser.feed(data.decode('utf-8', 'replace'))
- result['feed'] = feedparser.feeddata
-diff --git a/setup.py b/setup.py
-index a4a60fe..8c15451 100644
---- a/setup.py
-+++ b/setup.py
-@@ -16,7 +16,7 @@ setup(
- download_url = 'http://code.google.com/p/feedparser/',
- platforms = ['POSIX', 'Windows'],
- package_dir = {'': 'feedparser'},
-- py_modules = ['feedparser'],
-+ py_modules = ['feedparser', '_feedparser_sgmllib'],
- keywords = ['atom', 'cdf', 'feed', 'parser', 'rdf', 'rss'],
- classifiers = [
- 'Development Status :: 5 - Production/Stable',
---
-1.7.8.1
-
diff --git a/dev-python/feedparser/files/feedparser-5.1.3-backport_fix_for_chardet-py3.patch b/dev-python/feedparser/files/feedparser-5.1.3-backport_fix_for_chardet-py3.patch
deleted file mode 100644
index 6b03ddea8cbb..000000000000
--- a/dev-python/feedparser/files/feedparser-5.1.3-backport_fix_for_chardet-py3.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 20a32910f4a521788ba93a8c809cf0db702bed5b Mon Sep 17 00:00:00 2001
-From: Kurt McKee <contactme@kurtmckee.org>
-Date: Mon, 17 Dec 2012 10:41:13 -0600
-Subject: [PATCH] Fix chardet support in Python 3
-
-Fixes issue 384.
-Thanks to Google user Arfrever.TFA for reporting this!
----
- NEWS | 1 +
- feedparser/feedparser.py | 6 +++++-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/feedparser/feedparser.py b/feedparser/feedparser.py
-index c78e6a3..e977ae8 100644
---- a/feedparser/feedparser.py
-+++ b/feedparser/feedparser.py
-@@ -3766,7 +3766,11 @@ def convert_to_utf8(http_headers, data):
- chardet_encoding = None
- tried_encodings = []
- if chardet:
-- chardet_encoding = unicode(chardet.detect(data)['encoding'] or '', 'ascii', 'ignore')
-+ chardet_encoding = chardet.detect(data)['encoding']
-+ if not chardet_encoding:
-+ chardet_encoding = ''
-+ if not isinstance(chardet_encoding, unicode):
-+ chardet_encoding = unicode(chardet_encoding, 'ascii', 'ignore')
- # try: HTTP encoding, declared XML encoding, encoding sniffed from BOM
- for proposed_encoding in (rfc3023_encoding, xml_encoding, bom_encoding,
- chardet_encoding, u'utf-8', u'windows-1252', u'iso-8859-2'):
---
-1.8.5.5
-