summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-06-08 23:55:15 +0100
committerMarek Szuba <marecki@gentoo.org>2022-06-09 00:11:02 +0100
commit3b8369c3980e41ecd6571b66a548dc6fdea88b04 (patch)
treef9b16af679b2a49673d1795abbf1f5bdc785e82b /dev-python/fido2
parentapp-admin/github-backup-utils: call python-any-r1_pkg_setup conditionally (diff)
downloadgentoo-3b8369c3980e41ecd6571b66a548dc6fdea88b04.tar.gz
gentoo-3b8369c3980e41ecd6571b66a548dc6fdea88b04.tar.bz2
gentoo-3b8369c3980e41ecd6571b66a548dc6fdea88b04.zip
dev-python/fido2: add 1.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-1.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 0ba0a3f09459..5b542fcc282d 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1 +1,2 @@
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
+DIST fido2-1.0.0.tar.gz 245631 BLAKE2B e9ee319c19a9d4b687958ee2f9b2b809b8fa1d41bd278bbd7e26a5bbcab51791d6b8565dd6cdb6abf6804db4604f4b02e2d7e73cbbf2a237d72a0679c3ebcf49 SHA512 778128fb4fd459bd096eb440034a08c8883bfd29dbe834f3affb451032a5d5a22c79ca71be257b3c333a9d9890602558502848e83cd3efab4b6d6762e0622670
diff --git a/dev-python/fido2/fido2-1.0.0.ebuild b/dev-python/fido2/fido2-1.0.0.ebuild
new file mode 100644
index 000000000000..8c2ea92378be
--- /dev/null
+++ b/dev-python/fido2/fido2-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="<dev-python/cryptography-40[${PYTHON_USEDEP}]
+ <dev-python/pyscard-3[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}