summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-18 07:36:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-18 08:36:30 +0200
commit7cad8aea439ff4bdb642d5e36bfe074f35778d6c (patch)
treec00974d1d08bbb3afae395f8432a781f1045b049 /dev-python/fido2
parentdev-python/google-auth: Bump to 2.13.0 (diff)
downloadgentoo-7cad8aea439ff4bdb642d5e36bfe074f35778d6c.tar.gz
gentoo-7cad8aea439ff4bdb642d5e36bfe074f35778d6c.tar.bz2
gentoo-7cad8aea439ff4bdb642d5e36bfe074f35778d6c.zip
dev-python/fido2: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-1.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 5b542fcc282d..2f6bda07a05c 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,2 +1,3 @@
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
DIST fido2-1.0.0.tar.gz 245631 BLAKE2B e9ee319c19a9d4b687958ee2f9b2b809b8fa1d41bd278bbd7e26a5bbcab51791d6b8565dd6cdb6abf6804db4604f4b02e2d7e73cbbf2a237d72a0679c3ebcf49 SHA512 778128fb4fd459bd096eb440034a08c8883bfd29dbe834f3affb451032a5d5a22c79ca71be257b3c333a9d9890602558502848e83cd3efab4b6d6762e0622670
+DIST fido2-1.1.0.tar.gz 243526 BLAKE2B 48a6466c1ad3723d3d5f2e22ef59b4b49ebc3231739ffffdb25349d466c23f5cdc063908ea1adb944041f646d0bd0648d66acdaae0e72a9715e4bc365f449c12 SHA512 df7fcf205a5c124daf14c4bb7742aa16def1e912490c3b967dd940fdb21baf1a933130eab276af7c03fb46fb779a5a2b8e5fa3d8e3cd379297c23d9f39cadba4
diff --git a/dev-python/fido2/fido2-1.1.0.ebuild b/dev-python/fido2/fido2-1.1.0.ebuild
new file mode 100644
index 000000000000..da7a80ee9ab6
--- /dev/null
+++ b/dev-python/fido2/fido2-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="
+ https://github.com/Yubico/python-fido2/
+ https://pypi.org/project/fido2/
+"
+SRC_URI="
+ https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/cryptography-40[${PYTHON_USEDEP}]
+ <dev-python/pyscard-3[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}