summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-10-24 11:26:49 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-10-24 11:27:05 -0400
commitdd287b62856673f91fb002b313dbd1b969063a05 (patch)
tree55e627295fca22b272e1bd7aca14c66615d5f036 /dev-python/fido2
parentnet-wireless/iwd: bump to 0.23 (diff)
downloadgentoo-dd287b62856673f91fb002b313dbd1b969063a05.tar.gz
gentoo-dd287b62856673f91fb002b313dbd1b969063a05.tar.bz2
gentoo-dd287b62856673f91fb002b313dbd1b969063a05.zip
dev-python/fido2: bump to 0.7.2
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.7.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 23708cfcded0..46d7e85dd8c0 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -4,3 +4,4 @@ DIST fido2-0.5.0.tar.gz 161562 BLAKE2B 20d4f6c4e54366a26d5a56a84a6ff84bec0f0e221
DIST fido2-0.6.0.tar.gz 163137 BLAKE2B 3a30d4267a1aae00eac8fa8c05065163f992b72895097aca95dba72300bd9c30373c7537a867e532949af779e8e7528e1a3aad8f04cb0170678675294757b5d4 SHA512 1fb8e591480ac2ac9c405e4fc74895d55d630e462626f849952193c3ae6720104cca1da47af1f89adbcc026034f69dba12fc38577b00f9802434db2162d0d1d5
DIST fido2-0.7.0.tar.gz 171787 BLAKE2B 6458a606ecbbd22ac7c49b2e32b46e43c0ca184645fff4c54e0204f044a415db05b3e7187b6138e4d1b67dad9ed5faf3eb561b11b391b5105bac4299481bd95d SHA512 65fdaeeb1932873fb2ae86257182eb6098d6bf4ce5ed45336327bd3e9040eddccd7f7559ece58d9bdcbfe8c98c2eb8646069556a6d00035fef5eade4907a45d8
DIST fido2-0.7.1.tar.gz 176790 BLAKE2B d6e800b750902ad26ea6fc0634b37215ac57a65c18d0139b38263d7b97fdf0aaa41070abd5da35891a0dee0c788e43cc7c3bf47e8c1328e292352612ad719c9b SHA512 07024a4076d88bd9ec5d5dbfd924c88e314906668444d96aa9177c373309e90e33c18fd5313943fd83eb28b6d40f0c16a8f64c5d9a2aa50f2fc5115c1967ae3a
+DIST fido2-0.7.2.tar.gz 188159 BLAKE2B b1fa5f260c64bcfbed7e84aeda4d2ccd4582c8889f9b2369faf677139e0fafb30ae9633e89baf789c3e6e343f63932cfbf9161a41c27b60b59f81a625804d1ab SHA512 dbd163f0700e57c3692da3817a79af616cab0a47f984cede8c098a8a81b31aa49e96c6087fb438fee62c251139af8a434b39175d87530fdc005047b2afdef3b1
diff --git a/dev-python/fido2/fido2-0.7.2.ebuild b/dev-python/fido2/fido2-0.7.2.ebuild
new file mode 100644
index 000000000000..311a481c34f0
--- /dev/null
+++ b/dev-python/fido2/fido2-0.7.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyfakefs-3.4[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}