summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-15 13:17:26 +0100
committerSam James <sam@gentoo.org>2022-01-28 05:16:43 +0000
commitc70d4167b9e811713d0c9e740f4e35cef4727235 (patch)
tree31068f8af1c11e59b3d672955cdef917f22b631d /dev-python/filebytes
parentdev-python/yara-python: run tests, convert to PEP517 (diff)
downloadgentoo-c70d4167b9e811713d0c9e740f4e35cef4727235.tar.gz
gentoo-c70d4167b9e811713d0c9e740f4e35cef4727235.tar.bz2
gentoo-c70d4167b9e811713d0c9e740f4e35cef4727235.zip
dev-python/filebytes: new ebuild
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/filebytes')
-rw-r--r--dev-python/filebytes/Manifest1
-rw-r--r--dev-python/filebytes/filebytes-0.10.2.ebuild25
-rw-r--r--dev-python/filebytes/filebytes-9999.ebuild25
-rw-r--r--dev-python/filebytes/metadata.xml20
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/filebytes/Manifest b/dev-python/filebytes/Manifest
new file mode 100644
index 000000000000..d2bf3d9b8638
--- /dev/null
+++ b/dev-python/filebytes/Manifest
@@ -0,0 +1 @@
+DIST filebytes-0.10.2.tar.gz 1958114 BLAKE2B 6b7fb865d01cc9ea0f14b32f6e0326da21fa2fa2a36549b99ca88e9bf015162d3b0f82e350be1cca805294fd56ef47e2db4394db5ffb3061773f146eda1ba666 SHA512 12317d6b5063e710b4410e4dcc61b45c0ac1cbc80655212dacb0929a19e100849df39ba84a05cb96699abe7ec16758e0b9656b3d3ce044f3d122b8636106e564
diff --git a/dev-python/filebytes/filebytes-0.10.2.ebuild b/dev-python/filebytes/filebytes-0.10.2.ebuild
new file mode 100644
index 000000000000..6dcf19310aed
--- /dev/null
+++ b/dev-python/filebytes/filebytes-0.10.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Classes/Types to read and edit executable files"
+HOMEPAGE="https://github.com/sashs/filebytes"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/filebytes"
+else
+ SRC_URI="https://github.com/sashs/filebytes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/filebytes/filebytes-9999.ebuild b/dev-python/filebytes/filebytes-9999.ebuild
new file mode 100644
index 000000000000..6dcf19310aed
--- /dev/null
+++ b/dev-python/filebytes/filebytes-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Classes/Types to read and edit executable files"
+HOMEPAGE="https://github.com/sashs/filebytes"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/filebytes"
+else
+ SRC_URI="https://github.com/sashs/filebytes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/filebytes/metadata.xml b/dev-python/filebytes/metadata.xml
new file mode 100644
index 000000000000..11063ba5138e
--- /dev/null
+++ b/dev-python/filebytes/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ Python library to read and edit files in the following formats:
+ Executable and Linking Format (ELF), Portable Executable (PE), MachO
+ and OAT (Android Runtime)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sashs/filebytes</remote-id>
+ </upstream>
+</pkgmetadata>