summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-01 08:37:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-01 09:21:32 +0200
commit851d4ef389805261edb1fdd5611ae8b7776cf318 (patch)
treed2c098c2a240fec8d666b3644a9ce375247ea791 /dev-python/filelock
parentdev-python/alembic: Bump to 1.8.0 (diff)
downloadgentoo-851d4ef389805261edb1fdd5611ae8b7776cf318.tar.gz
gentoo-851d4ef389805261edb1fdd5611ae8b7776cf318.tar.bz2
gentoo-851d4ef389805261edb1fdd5611ae8b7776cf318.zip
dev-python/filelock: Bump to 3.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.7.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 818610c1dd53..aa0baf310a64 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1,2 +1,3 @@
DIST py-filelock-3.6.0.tar.gz 204238 BLAKE2B f65a6e8ca8645dbeaf5ebbad00a8001cd88065da997097ef2ce74b5eee4dabfaf44d53a240498e82905589943f045422b44776c3b8de3077656a3b9612396156 SHA512 f55ad90d79e90eb5a915afffecc632566456604a62b89fb13304c5812e05a34c508c863e76246a254acd98f55930d3179b0908a06d1e5a203d578a826a048ae2
DIST py-filelock-3.7.0.tar.gz 204366 BLAKE2B 9ef0a488603a5d210a232e472d2bcdce7f867b7b3fdb8dbe167dde54cd8c7085561f09d5a746ad7565ae7853495bd84c0b14cfa136a9d466f18f037ea0b9e8d1 SHA512 1b01a25a1ec194be1727a7245d6bada3a5f6e38bc16c0c78793ec0cf3dcdee6cc6b5c04fc74ae3687afd354379c73e189f7f3a8964853b8533a489ed2a0c6a04
+DIST py-filelock-3.7.1.gh.tar.gz 204373 BLAKE2B e3ef657488a68caf8dc8158d5060a07447b74b53b26a2ad05eb67211a5ae7ef5deadeb8527cb6cd95ce225e0fcd29a0ce2dd53b68b7e2cacde4c0f2242966b21 SHA512 66708398ae3c4dcd97a6031feca6a1b7d1010a5ee605c5adce29a9cfabe67c5464eefb3812c66e2c32c3547240fdc7acac6eec25cc8dfb2d5255079c5e6b44b4
diff --git a/dev-python/filelock/filelock-3.7.1.ebuild b/dev-python/filelock/filelock-3.7.1.ebuild
new file mode 100644
index 000000000000..320e582a2a70
--- /dev/null
+++ b/dev-python/filelock/filelock-3.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+SRC_URI="
+ https://github.com/tox-dev/py-filelock/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}