summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-03 21:56:01 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-03 22:39:24 +0200
commit4565e9e33fefacd7797724e931b6d4e0e385ef14 (patch)
treed017a54fb979ed657a8fd033316ce573aaf3bbfd /dev-python/filetype/filetype-1.0.10.ebuild
parentdev-python/uvicorn: add 0.17.3 (diff)
downloadgentoo-4565e9e33fefacd7797724e931b6d4e0e385ef14.tar.gz
gentoo-4565e9e33fefacd7797724e931b6d4e0e385ef14.tar.bz2
gentoo-4565e9e33fefacd7797724e931b6d4e0e385ef14.zip
dev-python/filetype: add 1.0.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/filetype/filetype-1.0.10.ebuild')
-rw-r--r--dev-python/filetype/filetype-1.0.10.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/filetype/filetype-1.0.10.ebuild b/dev-python/filetype/filetype-1.0.10.ebuild
new file mode 100644
index 000000000000..6891e931dbe6
--- /dev/null
+++ b/dev-python/filetype/filetype-1.0.10.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Small, dependency-free, fast Python package to infer binary file types checking"
+HOMEPAGE="https://github.com/h2non/filetype.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest